Jump to content

High Sierra on Dell L502x


yudi.153
 Share

Recommended Posts

Hi, I installed High Sierra quite difficultly on my L502x . and got the vanilla kexts , but my Graphics are not working properly.. I get heavy glitches and my system hangs while using Safari , for example if I minimize Safari it gets hanged and then I have to forcibly restart my laptop. Please guide me some easy way so I can work this out.  I am using Clover v4297. I previously used a distro. But now I am using the High Sierra app downloaded from Mac Store.

Link to comment
Share on other sites

Use the attached config.plist file.

 

Note: I have only changed SMBIOS and injected graphics properties.

 

Note2: You may see that snb-platform-id in Devices > Add Properties is enabled but the other two patches namely, hda-gfx and AAPL,os-info are disabled. You may try toggling them incase you don't get QE/CI.

 

Regards

config.plist.zip

Link to comment
Share on other sites

  • Administrators

Your IOReg shows a system with dual GPU so if you want to run on the HD3000 iGPU only, you probably ought to disable the nVidia dGPU to begin with. This can be done through DSDT + SSDT patching. You can try the patched files below in your Clover ACPI/patched folder:

DSDT.zip SSDT-1.zip

 

Then, on the basis that you have a HiRes built-in LCD, I would recommend that, instead of using the ACPI patching method advocated by black.dragon74, you actually setup HD3000 graphics as follows using Clover Configurator app:

  1. adjust your Clover config as follows because the current one is rather erroneous:
    • change GFX0 to iGPU ACPI patch (add the USB controller patches too)
    • inject Intel graphics
    • set SNB layout-id to 0x00020000
    • set DualLink to 1
    • set SMBIOS profile to MacBookPro8,3

Correct_ACPI_patches.png

Graphics settings.png

SMBIOS.png

 

Once this is done, generate your CPU-specific power management SSDT using Pike R Alpha's well-known generator tool and adjust your Clover config from this:

Incorrect_ACPI.png

to this:

Correct_ACPI_CPUPM.png

 

Place the generated SSDT in your Clover ACPI/patched folder and reboot. Hopefully, you'll be all set.

Link to comment
Share on other sites

@

 

Your IOReg shows a system with dual GPU so if you want to run on the HD3000 iGPU only, you probably ought to disable the nVidia dGPU to begin with. This can be done through DSDT + SSDT patching. You can try the patched files below in your Clover ACPI/patched folder:

attachicon.gifDSDT.zip attachicon.gifSSDT-1.zip

 

Well sir these files when I placed into Clover/acpi/patched, and opened the system preferences->Graphics/displays . I still see both of my GPU's there... So I planned to place the previous DSDT and SSDT files which you and Jake Lo provided me in previous post and it showed me only the Intel GPU in my preferences... attaching those files. Else than that the only part I don't get is the Pike R Alpha's well-known generator tool , how to generate ssdt from this file?

 

and secondly my lcd is 1366x768 so do I need to set DualLink to 1?

Link to comment
Share on other sites

 Share

×
×
  • Create New...