Jump to content

ig-platform-id


Jay-Jay
 Share

Recommended Posts

  • Administrators

You have a laptop fitted with mobile HD4600 (id 0x0416). The usual Azul framebuffer required for this kind of platform is #12 0x0a260006, not 0x0d220003 which is normally used on Desktops.

 

Of course, graphics acceleration on mobile HD4600 requires that the choice of Azul FB is accompanied by mandatory faking of desktop HD4600 id 0x0412, the injection of Rehabman's FakePCIID kexts (FakePCIID + FakePCIID_Intel_HD_Graphics at a minimum) and the right SMBIOS profile (should be MacBookPro11,1 or similar). Then, even with these correct settings, you may still require to inject a correct EDID for your built-in screen but start with the correct basic settings 1st...

 

I could not find where you inject fake desktop id 0412 from: I saw this in your IOReg output but it's not in your Clover config file and I could not find this injected your patched DSDT either...

 

NB: I don't think you should need those kexts you currently inject via Clover: it's not in your Clover config file and I could not see it in your patched DSDT either...

  • AppleBacklightInjector
  • IntelGraphicsDVMTFixup
  • IntelGraphicsFixup
  • Like 1
Link to comment
Share on other sites

  • Administrators

he might only need  the IntelGraphicsFixup from those kexts above he should also add shiki and lilu they should correct a few graphics glitches and youtube / safari  issue freeze. also if you just use inject intel in config the newer clovers will auto detect all the parameters for you like ig-platform and whether it is high resolution or low. it would show in the clover boot log. 

in my case i also need the rehabman fakepcid kexts as Herve linked too and the smbios MacBookPro11,1. also are you sure you have HD4600 on a mobile? ususally its a HD4400 or HD4200 which has to be faked to HD4600 as Herve also mentions.

  • Like 1
Link to comment
Share on other sites

Hello Herve, Bronxteck... thank you both for your time and replies  :-P

 

With Core i7-4710QM Intel integrated HD4600 I am unable to use ig-platform-id  0x0a260006.  I tested 0x0a260006 with Fake ID 0x04168086 and FakePCIID + FakePCIID_Intel_HD_Graphics and my Thinkpad boots to a black screen.

 

I also tried different kext combinations, also injected EDID plus a custom EDID following excellent instructions here at OSXLatitude but laptop will still boot to a black screen. 

 

 

Out of 16 Haswell ig-platfrom-id's my Thinkpad will only work with the following:

 

  • Desktop - 0x0d220003 --- > with Graphics Acceleration QE/CI but not perfect.
  • Mobile - 04160002       --> No Graphics Acceleration
  • Mobile - 0a260008       --> No Graphics Acceleration

 

The recommended mobile: 0x0a260006 with Fake ID 0x04128086 and RM's FakePCIID + FakePCIID_Intel_HD_Graphics seem not to work with i7-4710QM.

 

 

At the moment I have graphics acceleration QE/CI using the minimum configuration:

 

  • VID to IGPU with ACPI DSDT Patch
  • Fake ID with no ID set
  • ig-platform-id: 0x0d220003
  • IntelGraphicsFixup.kext ( with AppleBacklightInjector + IntelGraphicsDVMTFixup both removed )
  • MacBookPro11,2
  • If I remove IntelGraphicsFixup.kext from the minimum configuration above then the laptop will have no graphics acceleration.

 

I also tried smbios MacBookPro11,1 and had same problem. 

 

Can you think of anything else that I could test, had a google around and there is loads of helpful Thinkpad T440 guides and no T540p's .

Please can you bear in mind, I'm not the most advanced hackintosher when it comes to DSDT / SSDT and patching. 

 

I there anything that I could be missing that is preventing recommended ig-platform-id  0x0a260006 from working.

 

:)

Link to comment
Share on other sites

I tested backlight with torch, its not a backlight issue. 

What I have discovered, if I replace Fake IntelGFX 0x04128086 with  IntelGFX 0x04168086 then i am able to successfully boot with graphics using all the mobile Hawsell ig-platform-id's such as 0x0a260006 but I don't have  graphics acceleration.

 

So i'm still stuck using Desktop Haswell ig-platform-id 0x0d220003 for graphics acceleration with QE/CI on laptop. So far it seems like I'm unable to use the mobile ig-platform-id. 

Link to comment
Share on other sites

  • Administrators

Afaik, you MUST fake desktop id 0412. OS X/macOS just bears no support for mobile HD4600 (id 0416). But, as Bronxteck stated above, it would appear that IntelGraphicsFixup kext does that transparently. Hence the 0412 id in IOReg.

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...