Jump to content

Brightness control 7480 - High Sierra


karde
 Share

Recommended Posts

Hi,

 

Trying to get brightness control to work in High Sierra on a Dell Latitude 7480..

The display is generally dark, and brightness control in system setting won't work 😕 - thanks for any help!

 

 

 

Link to comment
Share on other sites

  • Moderators

Remove AppleBacklightInjector.kext from Clover kext, should only run in /L/E

but don't think that's the issue, looks normal in IOReg.

I remember others with this same or similar model having similar issue.

It works perfectly after waking from sleep.

Give that a try.

Link to comment
Share on other sites

Thanks, didn't make any difference, but..

 

I noticed now that the problem looks like this:


On boot the display is slightly dimmed, I can then adjust it to get it brighter, then, I can't adjust it to get as dark as it was on boot, but If I hold the brightness adjuster and slide it down it gets darker when! I almost am hitting the darkest settings (now the display is really dark), I can then adjust it to the brighest, but, seems like there's no in between.

 

Link to comment
Share on other sites

  • Moderators

delete nvram.plist in /EFI

reinstall Clover with these settings:

  • Install for UEFI booting only
  • Install Clover in the ESP
  • Drivers64UEFI\AptioMemoryFix-64 (leave the other default as is/ uncheck all other Aptio*)
  • Install Clover Preference Pane 

Make sure you don't have OsxAptioFix2Drv-64.efi or OsxAptioFixDrv-64.efi in /EFI/Clover/driver64UEFI

Link to comment
Share on other sites

 Share

×
×
  • Create New...