Jump to content

10.14.1 in Dell Precision 5530


Recommended Posts



I'm trying to get my UHD630 properly detected in 10.14.1 on a Dell Precision 5530 laptop, but I'm failing miserably...


Its an intel 8 series CPU, with 32G RAM, 1920x1080 screen, Nvidia Quadro P1000, thunderbolt, etc...


I've attached my current EFI (with preboot.log & clover F4 original .aml files), which has allowed me the following:

  • Full CPU power management
  • Sound
  • Bluetooth
  • USB 3.1 (seems OK) 


A user MaLD0n created the DSDT.aml in patched folder.


Also attached my IOReg.


Thanks for any help!





Dell Precision 5530 (mac).ioreg.zip


Link to comment
Share on other sites

Thanks again - sorry I had to go to bed yesterday 😉


Added, but it seems the result is still the same...


I've attached the preboot.log:



Also, the output of lspci:



I've read that maybe the Nvidia Quadro P1000 card might need to be disabled, no ?


How can I provide you with more detail boot log ?



Link to comment
Share on other sites

Good evening - thanks!


Noticed that you disabled the DSDT patch for PEGP to GFX0 and changed SMBIOS into MacBookPro14,3...


But still the same, unfortunately...


I've attached the RunMe data from this configuration for your analysis please.

Send me Dell-Precision-5530-mac.zip


How about the DSDT.aml ? do you think it needs any change or being disabled ?



Link to comment
Share on other sites


  • Create New...