Jump to content

Plz help getting the kext for my 5480/5488


micgo
 Share

Recommended Posts

Hello i have try a few diff efi folder from this site and all of them giving me KP, can someone help me with the kext ? i have made a mojave 10.14.3 for my other dell system. i used it to boot and installed 10.14.3 on this 5480. i think the CPU and IGPU is wrong. but i was able to boot and got it installed

 

i know the intel wifi is not able to be use in hackintosh. i have already got a DW1820A, but i m not able to boot with it. i think i need to use the right kext as well. the DSDT have been dump as well.

 

Here is my hardware, maybe can help on others. the only 2 hardware i have replaced from stock were the wifi and nvme

 

BIOS Version: 1.13.0

 

Working :

Bluetooth 4.0 (BCM20702A0) Product ID: 0x216f Vendor ID: 0x0a5c Version 1.12

Camera

Ethernet: Intel I219LM4 PCI Express Gigabit Ethernet Vendor ID: 0x8086 Device ID: 0x15d7

Graphics: Intel FHD Graphics 520 VRAM 1536 MB Device ID: 0x1916 Revision ID: 0x0007

NVMExpress: SAMSUNG MZVLW256HEHP-000L7

USB: USB 3.0

Wifi: DW1560

 

NOT working:

Card Reader (i think no kext were installed)

 

 

 

Link to comment
Share on other sites

i m trying to use DPCIManager to Repair permissions and rebuild cache, a log windows pop out but show nothing.

 

where do i put CopyToLE ? on the efi boot partition or the mojave drive ?

 

look like there is something wrong with the wifi/AirportBrcmFixup.kext. i was able to see the wifi icon and i was able to search for my wifi SSID. but then once i put in the password everything just hangs. i had to force shut down the laptop

 

Link to comment
Share on other sites

  • Moderators

copy the kexts to /Library/Extension on the Mojave drive

      sudo chmod -Rf 755 /L*/E*

      sudo chown -Rf 0:0 /L*/E*

      sudo touch -f /L*/E*

      sudo chmod -Rf 755 /S*/L*/E*

      sudo chown -Rf 0:0 /S*/L*/E*

      sudo touch -f /S*/L*/E*

      sudo kextcache -Boot -U /

Link to comment
Share on other sites

got the 3 kext copied to LE

 

is this the output i m looking for ?

 

micgos-iMac:~ micgo$ sudo chmod -Rf 755 /L*/E*

micgos-iMac:~ micgo$ sudo chown -Rf 0:0 /L*/E*

micgos-iMac:~ micgo$ Sudo touch -f /L*/E*

micgos-iMac:~ micgo$ sudo chmod -Rf 755 /S*/L*/E*

micgos-iMac:~ micgo$ sudo chown -Rf 0:0 /S*/L*/E*

micgos-iMac:~ micgo$ Sudo touch -f /S*/L*/E*

micgos-iMac:~ micgo$ Sudo kextcache -Boot -U /

Warning: /AppleInternal/Library/Extensions: No such file or directory

rebuilding //System/Library/PrelinkedKernels/prelinkedkernel

Kext with invalid signatured (-67062) allowed: <OSKext 0x7f8c605faae0 [0x7fff921788f0]> { URL = "CodecCommander.kext/ -- file:///Library/Extensions/", ID = "org.tw.CodecCommander" }

KernelCache ID: 16A70445FDE72433518E39976A8C7998

kextcache updated critical boot files, requesting launchd reboot

Link to comment
Share on other sites

i m still not able to use my wifi. don't look like it's just a wifi problem or the problem is coming from wifi. look like there is a lag or loop somewhere. i can open chrome for like 2 min and then my cursor will turn into a color wheel. same thing for finder and system preferences

Link to comment
Share on other sites

 Share

×
×
  • Create New...