Jump to content

[SOLVED] constant kernel panics installing Mojave - E7250


zogthegreat
 Share

Recommended Posts

Hi everyone!

 

I've been going nuts trying to get Mojave running on my E7250. I can do a base system install, but on reboot, I get a kernel panic. The problem appears to be with my video, (output below)., and I seem to be getting 2 different KP's, depending on which bootpack that I try. I have tried every boot pack that I can find with no luck. The weird thing is that I was able to install Mojave on my E7450 with no problem using the E7x50_Mojave.zip boot pack. However, swapping the drive from the 7450 to the 7250 produces a KP.

 

 I'm using BIOS version A20. Bootpack's that I have tried are: 

 

Standard Clover base install EFI pack  and the generic EFI_r4910   // I have tried both of these as my base 

 

Then I have tried adding to each :

E7x50_Mojave

E7250_A17_HS

E7250_A19_HS

E7450_HD5500_Only

E7250_elisir1998

E7250_HS_abottwool

E7450_HD5500_Only_A19_HS


Does anyone have any suggestions?

 

Thanks!

 

zog

error_1.jpg

error_2.jpg

Link to comment
Share on other sites

Thanks Jake Lo, but it didn't work :(

 

Once again, it installed perfectly, but on reboot to finish the install, I got a KP again. Is there any way to capture the complete boot output? It looks like I'm having problems with the Intel video. I think that I need to do a little old school line by line to figure out what's going on. I'm also going to try doing a Sierra install and see if I get the same problem. 

 

BTW, that panel that I mentioned to you came in today and it worked straight out of the box. I can't wait to get it installed and setup! :)

 

 

IMG_20190416_093544.jpg

Link to comment
Share on other sites

  • Moderators

Hmm, the version of the kexts shown above tells me you're not booting from the links I linked.

Lilu v1.2.2

Shiki 2.24

AirportBrcmFixup 1.1.1

That's just to name a few. Shiki should not even be use anymore since it now packaged into Whatevergreen.kext.

Check the EFI that the system is really booting from and update that folder.

You could try continue booting with added boot arg -igfxvesa

Then update the files

Link to comment
Share on other sites

OK, I somewhat embarrassed here, since this is something that I should have thought of. It seems that the right side USB port is slightly defective. I noticed that I kept getting KP's at different places in the boot process. I rebooted the system with a Linux USB stick and I saw that the boot stick unmounted on it's own. I reboot with the OSX Mojave stick in a different port and everything worked properly.

 

Sorry about wasting your time Jake Lo! 😲

 

BTW, how to I mark this thread solved? Thanks!

Link to comment
Share on other sites

 Share

×
×
  • Create New...