Jump to content

[Solved] MC7710 on mojave 10.14 can't connect


Recommended Posts

On windows and linux , It works well ,but on macos I can't use it to connect the internet.


Here is the Info.plist of Legacy_Sierra_QMI_10.13.kext that I have used.



<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<string>Legacy Sierra QMI</string>
<key>0x199/0x68a2 MC7710</key>
<string>Sierra GSM Personality</string>
<string>Sierra Wireless</string>




And other information















Link to comment
Share on other sites

  • Administrators

That "Key" field is just like a title, so if that's the only thing you modified, it's not possible that it made a change in terms of operations; you must have changed something else.


In addition if you opted to modify the vendor id of your dedicated entry from 0x1199 (i.e. 4505 in decimal) to 0x(0)199 (i.e. 409 in decimal), then your dedicated entry no longer applies to your hardware (its ids obviously will not change!) and another profile is being used instead...

Link to comment
Share on other sites

I don't know anything else what I have done.

And I have uninstalled the SierraWirelessDrivers.

$ ls -al /dev/tty.*
crw-rw-rw-  1 root  wheel   21,   6 May  6 17:45 /dev/tty.Bluetooth-Incoming-Port
crw-rw-rw-  1 root  wheel   21,   2 May  6 17:45 /dev/tty.wwan
crw-rw-rw-  1 root  wheel   21,   4 May  6 17:45 /dev/tty.wwanDM
crw-rw-rw-  1 root  wheel   21,   0 May  6 17:45 /dev/tty.wwanGPS

But the icon of LTE in the  top-bar displays unconnect always , I cannot use it .

I must go to the network preferences to connect the LTE , but the icon still shows unconnect  .

what can I do if I want to use it to connect or disconnect?



Link to comment
Share on other sites

  • Administrators

So the main change was the uninstallation of the SierraWireless drivers.


The WWAN icon may simply refer to a different piece of previously registered hardware from when you had the SierraWireless drivers installed. It may be like when you choose show the Bluetooth icon in the menu bar and then remove or disable the Bluetooth hardware: the icon stays there but is unusable.


Try and uncheck the box used to display the icon, then recheck it afterwards.


Link to comment
Share on other sites

I know that now!

It's very simple.

Because the icon  stands for the "MC7710" ,not "MC7710 2" in the network preferences .

So when I delete the "MC7710" and rename the "MC7710 2" by "MC7710" ,it works. 


And I can manage the LTE  by the icon .





Do u know how to use the Aircard watcher ?

I have tried to install many different editions ,but no one  can worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...