Jump to content

A few Problems with E6330 Mojave


Recommended Posts

Hi guys, I recently upgraded my E6330 from High Sierra to Mojave.  At the same time, I also made some more effort to get Turbo Boost working, software backlight control working, etc.  Today I patched my own DSDT for the first time (previously I was using a pre-patched DSDT from God knows where, it's been there since over a year ago when I hacked this laptop with Sierra).  Overall the patches I applied seem to have made stuff work, except for the problems listed below... These are the patches I applied:


[gfx0] Disable/Enable on_WAK/_PTS

[igpu] Brightness fix (HD3000/HD4000)

[igpu] HD4000 Low Resolution

[igpu] Rename PCI0.VID to PCI0.IGPU

[syn] Fix *pnp/pnp lower case Error

[sys] AC Adapter Fix

[sys] Add IMEI

[sys] Fix _WAK Arg0 v2

[sys] fix Mutex with non-zero SyncLevel

[sys] fix PNOT/PPNT

[sys] HPET Fix

[sys] IRQ fix

[sys] RTC Fix

[sys] Shutdown fix

[sys] SMBUS Fix

[usb] 7-series/8-series USB


At this point, I'm very close.  Turboboost works (thanks to a patched SSDT), backlight control works too (thanks to SSDT-PNLF and Whatevergreen, which I didn't have before), but I still have a couple problems that I've been working on for days that I can't quite figure out.


1. Trackpad and mouse prefpanes seem connected.  


When I change the scroll direction in the trackpad prefpane, it also changes in the mouse prefpane.  This makes it a pain to use a trackpad and a mouse, because normally, I would have to reverse the mouse while leaving the trackpad in its "natural" direction for it to act like it should (e.g. Windows style scrolling with the mouse).  I am totally clueless on how to fix this, or even if it's possible.  I believe this is the kext I ended up using as it seemed to work the best.  I did have to change the FingerZ in the info.plist from 30 to 15 to have a normal pressure sensitivity.

On 2/13/2017 at 10:50 AM, Bronxteck said:

just checked Herve. yeah no plugins just container. hence no trackpad or keyboard kext inside. forgot to check lol.


recompiled from source on post 582

VoodooPS2Controller.kext.zip 71.73 kB · 1189 downloads



2. Function keys don't work well.  Only F3 and F4 work as they should.  I can control brightness using the keys, but I have to press Fn+F3 for brightness down and Fn+Insert for brightness up.  None of the other function keys work, however, even when pressing Fn+.  Oddly, though, pressing Fn+F1 makes the machine shut down...


The problem is, because I used the above kext for PS2 keyboard and trackpad, I have no idea how to get a debug version of it so I can read the raw scancodes and remap the keys.


3. Battery status indicator is intermittent.  It works about 50% of the time.  Sometimes it works perfectly, but other times, it freezes.  It will freeze at whatever percentage it is during boot, and show the AC adapter as connected even when it isn't.  I've tried and tried and tried to get this to work with no luck.  In verbose mode, I can see "batteryinstalled: false" displaying several times in a row, even though the battery is of course installed.


4. USB 3.0 ports are recognized as USB 2.0.  The E6330 has three USB ports... one USB2.0+eSATA, and two USB3.0 ports.  However, as of now, all of the ports show as USB2.0 in system report>USB, and all of the devices operate at USB2.0 speeds.  


Attached is my EFI partition and IOReg (I think I exported it right...?).  Any help would be greatly appreciated.


Link to comment
Share on other sites

Update: Oddly enough, HWMonitor and Turbo Boost Switcher seem to recognize the battery's state of charge, even when the main indicator does not.  Right now, my macOS battery indicator (the normal one) reads the battery at 1% and plugged in, however both HWMonitor and Turbo Boost Switcher read the battery at 85% and plugged in (but the laptop is in fact NOT plugged in).  So it's like my battery reading is working, but it's also not....

Link to comment
Share on other sites

My laptop seems to be damaged.  The power button is acting like it's being held down constantly, so when I turn it on, it turns off a few seconds later.  Really getting on my nerves.  I think my motherboard is bad :(


I'll try these kexts you suggest and removing the USBInjectAll, if I can get the machine to stay on long enough :(


Link to comment
Share on other sites

Ok, I  took the laptop apart and cleaned the area around the power button with alcohol.  Running with the keyboard and trackpad (wrist rest piece) removed and showing the bare motherboard.  Using USB keyboard and mouse temporarily.


Anyway, I removed USBInjectAll and now the only USB kext is the one you suggested.  The ports do show up, but again, still only as 2.0 not 3.0.    Just to be clear, all of the ports are showing, but the USB 3.0 ports are showing in macOS as USB 2.0.


Battery kext seems to not be working either.  As before, HWMonitor and Turbo Boost Switcher Pro show the battery percentage correctly, but the macOS indicator does not.  They also do not report the power adapter being plugged in.  I booted with the battery installed and the adapter not plugged in, the macOS indicator shows the wrong percentage but shows it not plugged in (which is correct), but TurboboostSwitcherPro shows it as plugged in when it's not.


Rebooted again, and now the indicator is working.  Seems very intermittent still.


Have you looked at my DSDT?  Does everything look like it should for battery and USB stuff?


I just really don't understand why HWMonitor and TBS can read battery %age, but not the main macOS indicator... and neither seem to reliably know if it's charging or not.

Link to comment
Share on other sites

  • Administrators

If you want USB3.0 ports, you need to make sure your DSDT injects Darwin; no USB3.0 otherwise. Then you'll need to cache or inject FakePCIID + FakePCIID_XHCIMux kexts.


Link to comment
Share on other sites

Ok I'll look into that.  Thanks


Also, I notice that my external HDD is recognized as internal for some reason.  Normally it shows the drive on the desktop as orange (which means removable) but right now it looks like any other internal drive.


Link to comment
Share on other sites


  • Create New...