Jump to content

E5540 - Mojave - video, microphone and AppStore issues


Recommended Posts

I'm getting IGPU busy timeout when booting to Mojave from a laptop off state.  If I boot to Clover and then reboot the laptop without turning it off, or boot into windows, restart,  then boot to Mojave, everything works perfectly.  It's just when I turn my laptop on for the first time and boot to Mojave without restarting that I get this nag.   Strangely enough,  the laptop takes 15 to 20 seconds to post after turning it on from an off state.  I updated to the A23 bios and wonder if this has something to do with it.


Also not able to get the internal microphone to work. (audio inject is set to 12 in config.plist)  and opening the App Store causes the OS to slow down and become unresponsive.


Any help would be appreciated.

Link to comment
Share on other sites

  • Administrators

Try this revised Clover config instead of the current one you use; seems you got your knickers in a twist on the CPU power management & SMBIOS/serial numbers front... You should also get rid of FakePCIID_Intel_HD_Graphics kext since Lilu + WEG take care of your graphics.



I suggest you call it "config2.plist" and place it alongside your existing file, then manually call it from Clover main menu at startup to test.


Link to comment
Share on other sites

Herve, thank you for the suggestions.  I tried the config.plist and got rid of that kext.  However, all 3 issues persist.  The App Store temporarily worked after I signed into icloud, but then exhibited slowness issues again after a reboot.

Link to comment
Share on other sites

I fixed the App Store slowing down the OS by editing my config.plist and checking "FixLAN" under ACPI in Clover Configurator. 


I also fixed an issue with a crash and black laptop display after turning off an externally connected display to the HDMI port.  I followed the instructions here to inject a custom EDID in the config.plist.


If I could fix that annoying issue with the IGPU busy timeout on cold boot, the laptop would be 100% perfect with Mojave (bluethooth and wireless work after installing Broadcom card).  I believe the timeout issue might be related to the A23 BIOS.  Unfortunately, I'm unable to downgrade as the laptop reboots with no error after running the bios flash utility; either from the OS with various commands (/forceit) or from the embedded Dell Bios Flash Utility or from a bootable USB flash drive.  This is annoying....

Link to comment
Share on other sites

I noticed after I replaced my EFI folder with the your's, my HDMI audio no longer working.  So I kept your EFI folder in place, but overwrote the ACPI\patched folder and the config.plist with my original.  After doing so, HDMI audio now works and the boot problem is still fixed as well.  I believe my issues were arising from my drivers folder.  My drivers folder was named drivers64UEFI with associated files in it.  In your Clover folder you had drivers\UEFI and a different set of files than what I had.  I believe all my issues are resolved now.

Link to comment
Share on other sites

Any tips on getting the internal microphone to work?  This is the last non-working item .  I have the Realtek ALC3223.  I'm currently using layout ID 12, but have tried 11 and 13 which don't work.  I have AppleALC.kext in /Library/Extensions


Everything else working so far:

  • Internal speakers
  • HDMI audio and video
  • Screen wake
  • Bluetooth (needed to disable Bluetooth in BIOS and add boot arg brcmfx-driver=1 to prevent WIFI dropouts while using bluetooth audio)
  • WIFI
  • Internal LAN
  • SD card reader
  • Graphics w/ full acceleration
  • Trackpad and gestures
  • Sleep
  • Screen brightness (FN keys)
  • Volume buttons + mute
  • Battery monitoring
  • Hardware monitoring (CPU temps)


Link to comment
Share on other sites

  • Create New...