Jump to content

[Solved] Dell Latitude 7490 Mojave 10.14.6 various problems


Gemini44
 Share

Recommended Posts

Hello, Sorry my poor English,

I have Latitude 7490 with i5-8350, 32 gb Kingston 2666mhz ram (i upgraded 8gm ddr4 2400mhz), 500 gb samsung 970 evo plus nvme M.2 ssd, dw1560, 1.11.0 BIOS specs.

I used Hervé's topic Clover pack #7 (thanks a lot) but i did not success and always KP. So i tried different EFI packs (shared 7490 topics) and i started installation but i recived errors from installer at the and of the final stage but 7490 booted normally. Bluetooth (i did not see sys. pref.), trackpad and trackpad buttons is not working. System indicates my ram as 2400mhz.

I guess i have to edit my config files (different ram config and wifi). I know how is edit DSDT and SSDT files but i don't know which patches i should make. I did not find any guide for Latitude 7490, or can i use rehabman's guide? I want to more stable laptop). I posted my debug report file.

Thanks in advance.

 

debug_31725.zip

Link to comment
Share on other sites

I fixed touchpad issue via VoodooI2C.kext and VoodooI2CHID.kexts, thank you Jake Lo.

I enabled DellBIOSPatch.

But i have no Bluetooth device and touchpad buttons not working.  Right USB port has been working before when i installed VoodooI2C and VoodooI2CHIDkexts. Now not working. I attached debug file.

Do i need patch ACPI files for stable system?

Thank you all.

debug_20955.zip

Link to comment
Share on other sites

  • Moderators

In Herve's guide, he mentioned that the buttons are not working.

It's the kext's lack of support, you'll just have to wait for the developer to add more support.

Not working:

RTS525a microSD card reader

Touchpad buttons

TrackPoint

 

ACPI files are already patched with the hotpatches/SSDT's.

For Bluetooth, did you add BrcmFirmwareRepo.kext & BrcmPatchRAM2.kext?

It's all in Hervé guide you linked on the 1st post

  • Like 1
Link to comment
Share on other sites

I added BrcmFirmwareRepo.kext & BrcmPatchRAM2.kext to efi/Clover/kexts/Other folder and seems BT works.

Right USB port is not working, am i broke something about config or kexts?

Finally, should i install in efi kexts to L/E?

Thanks Jake Lo.

 

Link to comment
Share on other sites

I removed USBInjectAll.kext & USB port limit patches but it isn't worked and then i removed USBPort.kext too and reboot voila my usb hdd shows up.

I have a new problem my external drives shows as internal, is it normal?

Thanks in advance Jake Lo.

Link to comment
Share on other sites

 Share

×
×
  • Create New...