Jump to content

Inspiron 7537: macOS Catalina 10.15.1 Beta - Still waiting for root device


Recommended Posts

Hey everyone!

First, thank you for reading my post and your time spent on my issue!


CPU: Intel Core i7-4200U

GPU: Intel HD Graphics 4400 - NVIDIA GeForce GT 750M

RAM: 2X4GB DDR3L 1600 MHz

Storage: INTEL SSDSC2CW120A3



















Long story short, I am unable to boot to the Catalina installer, as when booting with -v the installer stops with the no entry sign saying "still waiting for root device". I know by now from research that it is a common issue, but I am unable to circumvent it. I am turning to you guys in hope of getting my installer to boot as you may have better understanding for laptop computer needs.

This post is a continuation of this one on reddit: https://www.reddit.com/r/hackintosh/comments/dlpge1/dell_inspiron_7537_macos_catalina_10151_still/

FYI: Renaming EC devices as Catalina requires it is useless, as my EC device is called "EC" in my DSDT. The DSDT was dumped by AIDA64 as I am unable to get Clover to dump it to my USB drive. 

I am using Rehabman's config.plist titled: config_HD4600_4400_4200.plist as conflig.plist.

Thank you once again. Any input is much appreciated!



Link to comment
Share on other sites

I tried the config.plist from this the attached config.plist_for_installer.zip of this older guide. It went on for a while, but ultimately stopped here. I guess it was no surprise. This config was probably old for Catalina's needs. So I think I may need a "good" config.plist. Can further help me?

EDIT: From this guide:


Link to comment
Share on other sites

Hey Jake! Thank you for your answer!

I have tried to let Clover dump my DSDT, but never worked. There is no ACPI folder on my EFI partition. Not with a keystroke FN/Shift, etc. either. Though, I have never tried with F4+F2, but let's see. 

I have no idea about Voodool2C. I mean I don't even have the kext for it. 😅

Link to comment
Share on other sites

  • Moderators

No ACPI folder found. 

If you boot with the Installer and press F4, the files should be extracted to the Installer's EFI partition. You might have to check the root of the drive for EFI folder if you install Clover Legacy.

Please verify.

Try creating a folder call ACPI inside the Clover folder before trying again.

Link to comment
Share on other sites

@Jake Lo

Yes, that's what I was trying to tell. I cannot make Clover to dump my DSDT with F4 or any other keystroke combination command. I did choose UEFI-installation with ESP just to make sure.

I'll trying creating an ACPI folder myself and see whether it changes anything. I will report back.

Thank you, Jake!

Link to comment
Share on other sites

Hey @Jake Lo, thank you for coming back to me so fast after that DDOS attack!

I am just flabbergasted at the magnificent work that you have done here! It booted up to the installer right away. Absolutely amazing. Just wow...! I am so happy, Jake! Would it be appropriate to donate some for your help? I have no idea how much time it may have taken to set up, but I would feel well if I couldn't honour your work. 

I am not going to install Catalina right away as I am yet to replace my WiFi card, and I am without any ethernet connection, so wouldn't like to risk anything.

Big applause to you, Jake! Thank you for your help!🤗👍

PS.: Is there any way for me to actually learn what kind of changes you made to the config.plist and to all the DSDT/SSDT files? I just don't want to be completely clueless about the files I am using, and it probably would be quite educational. I hope there is a easy way to sort-of read them and show changes, like if I am not mistaken with Clover Configurator, I guess?



Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...