Jump to content

E7240 catalina - battery sign not updating and bluetooth missing DW1510


faruktuef
 Share

Recommended Posts

hy guys...

 

i have a almost perfect working catalina install on my E7240.

 

I used the clover data from jakelo from this tread 2nd last post.

 

 

 

wifi is now working after using the clover data mentioned above, but I am missing bluetooth and my battery sign is not updating...

if I click on "show percentage" it shows the updated battery status, but then again not updating till I click again...

 

attached you'll find my complete EFI and a screenshot of the L*/E*

 

thanks

 

 

Bildschirmfoto 2019-10-28 um 14.19.59.png

EFI.zip

Link to comment
Share on other sites

  • Administrators

Erm, re: Bluetooth, you just don't throw in all the kexts re: Broadcom firmware patching! -_-

 

You need to read Rehabman's documentation:

https://github.com/RehabMan/OS-X-BrcmPatchRAM

 

Replacement IO80211Family kext will not load from /L/E, it has to be done in /S/L/E. See here:

https://osxlatitude.com/forums/topic/11138-inventory-of-supportedunsupported-wireless-cards-2-sierra-catalina/

 

Link to comment
Share on other sites

okay.. i removed BrcmFirmawareData,and BrcmBluetoothInjector ...  moved BrcmFirmwareRepo to S/L/E ... rebuild cache and permissions.... 

 

bluetooth is still not here..... battery sign still not updating..

 

 

2)  you say IO80211Family kext will not load from L/E, but my wifi started working after putting it in L/E.... ???

 

Link to comment
Share on other sites

THX,,,,, one issue less!! ;-)

 

@Hervé: IO80211 is loading from /L/E .. i tested... when deleted, my wifi does not start... i replaced the one in SLE, then it works again... to make sure, i did the not working to SLE and the working to LE.. wifi worked...

 

still strange, my battery update does not work...

pls check my new /L/E directory, if still some kexts shouldnt be here or are missing..

 

Bildschirmfoto 2019-10-28 um 20.06.30.png

Link to comment
Share on other sites

  • Moderators

You should remove BrcmPatchRAM2, keeping BrcmPatcRAM3 for bluetooth if you plan to add a Broadcom BT in the future.

As for the Battery, see Rehabman's documentation here

You could try setting different value for FirstPollDelay to get better results

 

2017-10-01 v1.81.4

add kernel flag "abm_firstpolldelay" to allow override of FirstPollDelay with simple kernel flag entry (config.plist/Boot/Arguments). For example, to set FirstPollDelay to 16000 (16 seconds), use abm_firstpolldelay=16000

Link to comment
Share on other sites

 Share

×
×
  • Create New...