Jump to content
npyadav1

[SOLVED] Dell E6530 Audio, Wifi not working Catalina 10.15.1

Recommended Posts

Audio works with Lilu + AppleALC + injection of layout 12. The stuff you posted shaw that you do, so there could be an issue with your patched ACPI tables (not provided).

 

Wireless depends entirely on the card you use. Refer to our FAQ section and wireless cards inventories.

Share this post


Link to post
Share on other sites

Thanks Herve,
Please check my ACPI folder and tell me how do I solve this problem and my laptop has a DW 1510 wifi card which was working in Mac (10.14.6) Mojave but not working in Mac (10.15.1) Catalina.
Please help me.

 

ACPI.zip

Share this post


Link to post
Share on other sites

Your patched DSDT injects layout 2, so that's incorrect and clearly clashes with your other audio settings:

        Device (HDEF)
        {
            Name (_ADR, 0x001B0000)  // _ADR: Address

            [...]

            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {

                [...]

                Return (Package (0x0C)
                {
                    [...]

                    "layout-id", 
                    Buffer (0x04)
                    {
                         0x02, 0x00, 0x00, 0x00                         
                    }, 

                    [...]

                })
            }
        }

Remove that from your HDEF _DSM, clear the item counter of the Return Package line (or reduce it from 12 to 10), recompile the DSDT and you will be good to go.

 

Re: DW1510, did you consult our wireless cards inventory ? Because the answer is there...

Share this post


Link to post
Share on other sites

The latest ACPI is set correctly. If you still don't have audio, it could be you need to update the kexts.

Latest version of AppleALC = 1.4.3

Lilu = 1.3.9

Whatevergreen = 1.3.4

VirtualSMC = 1.0.9

FakePCIID + FakePCIID_XHCIMux = 1.3.15

AirportBrcmFixup.kext = 2.0.4

You can find them in these links

https://github.com/vit9696/Lilu/releases 

https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md 

https://bitbucket.org/RehabMan/

 

Also since you're using static DSDT/SSDT, enable "Drop OEM" in the Config file

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...