Jump to content
PayPal donations: [email protected] ×
josenaves

Lenovo Thinkpad E470 - help with post install

Recommended Posts

I have a Lenovo Thinkpad E470 and I need some help with post-install.

 

Lenovo Thinkpad E470

Processor: Intel Core i5-7200U (Kaby Lake)

Bios: R0DET99W (1.99 )

Memory: 12GB (4+8)

Graphics: Intel(R) HD Graphics 620

Wifi: Qualcomm Atheros QCA9377 (interface NGFF M2)

Ethernet: Realtek PCIe GBE Family Controller

IDE Controller: Intel(R) 6th Gen Core Processor Family Platf I/O SATA AHCI Controller

SD Card Reader: BayHubTech Integrated MMC/SD controller

Motherboard chipset: Intel Sunrise Point-LP, Intel Kaby Lake-U

HDD: WDC WD5000LPLX-08ZNTT0  (500 GB, 7200 RPM, SATA-III)

Trackpad: Synaptics Pointing Device

Keyboard: Japanese PS/2 Keyboard (106/109 teclas Ctrl + Eisuu)

Áudio:

Conexant CX20753/4 @ Intel Sunrise Point-LP PCH - High Definition Audio Controller [C1] (codec: 14F15111h / 17AA505Bh)

Intel Kaby Lake HDMI @ Intel Sunrise Point-LP PCH - High Definition Audio Controller [C1] (codec: 8086280Bh / 17AA505Bh)

 

I have followed initially the guide below (it helped me a lot). Thank you guys for this @Max.1974 @Jake Lo!!!!

 

 

 

After a successful Catalina installation, I've used the CLOVER folder from the guide but it never boots up.

So, I did a clean install and used a config.plist from RehabMan. So far, so good (er, more or less).

During the boot I can see lots of ACPI errors.

 

I'm writing this message from the Lenovo E470 itself :) I've buy a SSD and I'm just waiting for it.

Meanwhile, I'm trying to make it (almost) perfect.

 

What's working:

  • network - only cabled (ethernet)
  • keyboard - although it is a ABNT2, I'm using it as a US International
  • trackpad - not as good as I need - sometimes the click is not working
  • trackpoint - works but not the buttons
  • video - activated and using an external monitor through HDMI 
  • screen brightness (with keyboard keys too)
  • SD Card Reader

 

However,  some things are not working:

  • sound - only through headphones - using layout 15 (have tried all possible layouts)
  • battery - not showing status
  • wifi - not using - maybe I buy some wireless card in the future (also have 2 different usb dongles to test)

 

Here is my current CLOVER folder and also codec_dump I made using Linux.

 

I want to make it fully functional and learn some new tricks during the journey.

I also want to make a more detailed guide to help other people.
 

Any help is welcome.

 

 

 

 

codec_dump-0.txt.zip

CLOVER.zip

Edited by josenaves
Update to brightness + clover update
  • Like 1

Share this post


Link to post
Share on other sites

Nothing to worry about those ACPI errors; you may just need some additional tuning re: DSDT/ACPI patching

  • Like 1

Share this post


Link to post
Share on other sites

Hi Jake, 

 

Thank you for your help.

 

Something bad happened here. I replaced the CLOVER folder but now the computer won't boot.

I'm trying to recover it.

 

Did I miss anything ?

Share this post


Link to post
Share on other sites

Thank you very much @Jake Lo. Everything is good now ! Wow ! The only thing that needs some working is audio. I've just injected layout 15 (at least I have sound through headphones).

 

One dummy question - why did my CLOVER folder won't work in another similar Lenovo E470?  It is something related with DSDT ?

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...