Jump to content

E7450 | Catalina 10.15.1 | bluetooth issue


acquarius.13
 Share

Recommended Posts

Hi everyone,

 

I apologize about opening this new topic. As I wrote on the subject, I'm still suffering bluetooth issues: it might be available, but it isn't able to connect to anything. Most of the time it doesn't switch it on at all: the icon on the topbar is shaded grey but in system preferences it appears active, even if it doesn't work at all.  

I also tried to patch the SSDT for UsbInjectAll.kext, with no success.

I tried to properly modify the USBPorts-E7450.kext, with no success. 

I'm still not so good in doing these things..can you please help me?

I manually saved the ioregistry file because the install_tool.sh wasn't able to do by itself.

 

Regards,

 

Marco

debug_23306.zip

Link to comment
Share on other sites

I confirm I have installed the latest version of BrcmPatchRAM (2.5.0) before posting here. So the issue appear with the latest version, but I'm pretty sure I have it also with 2.3.0d3.

Might it be a problem of virtualSMC?

 

many thanks

 

edit: a partial solution occurred putting the machine to sleep (by closing the lid) and leaving it there for a few minutes. After waking up, bluetooth is working correctly.

Do you have any possible hint?

 

Thanks again

Link to comment
Share on other sites

I don't want to talk too loud..but after updating to 10.15.2 the configuration seems to be working..

 

Is that correct to keep the SSDT-UIAC.aml (with proper USB configuration) and UsbInjectAll.kext (this one in /L/E)? If so, and if you agree, I might share my EFI folder with the community in a new git repo.

 

When still on 10.15.1 I tried deleting virtualSMC (and SMCBatteryManager) and replace it with FakeSMC (and ACPIBatteryManager) but bluetooth was not working..

Link to comment
Share on other sites

I tried an hard method: formatting anything and perform a clean install of Catalina 10.15.2. Result: no way. 
I suspect it can be a usb wrong configuration too: I tried to add the HP13 to usb20internalhub (which appears in IOregistryexplorer when I close/open the lid) in USB-E7450.kext through PlistEdit Pro (pic attached) but it’s again useless, probably because I wrote it in a wrong way. @Jake Lo can you please have a check?

 

thanks

 

Ps: if the problem is with no solution, I suspect I will have to downgrade to Mojave 

 

edit: in order to be clear enough, I just want to underline that bluetooth works only if I close/open the lid (waiting for the hack going to sleep). But at the first boot (or reboot) it doesn't work.

 

Bluetooth.jpeg

 

Link to comment
Share on other sites

Dear @Hervé,

I apologize for the wrong orientation of that pic. I will for to rotate it in the proper way next time.

Please consider that my E7450 has been formatted and I still don't have my password manager installed there. Without it, I cannot login to the forum.

So I apologize again.

 

Do you have any hint about our issue? I mean, mine and @pafkata?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...