Jump to content

Toshiba Satellite Pro A40-C-21D: Bluetooth module of DW1820A card not detected


skyfly555
 Share

Recommended Posts

Hello, I need help.

Bought a DW 1820A, supposedly being CN-0VW3T3-...

Received a DW 1820A, code: CN-096JNT-76772-5CJ-01F7-A00.

Device 14e4:43a3, but 106Bb:0022 subvendor:subdevice.

I've followed the @Hervétutorial (latest, 06 Jan 2020), and WIFI works OK (thank you very much, @Hervé!!!).

 

But I cannot get my BT recognised, macOS says there's no such a device.

Created some SSDT-UIAC-ALL.aml, playing with connectors (internal, USB2, USB3), no results: BT not detected, not showing up in IOREG neither. Checked BT is enabled on UEFI (even tried disabling it).

I hoped to find Bluetooth on HS7 or HS10 (images attached, too).

 

I attach debug files, hoping they can help.

My computer is:

Toshiba Satellite Pro A40-C-21D, Skylake-U, i5-6200U, 8 GB RAM, M.2 SSD.

 

Thank you,

usb-ports-ioreg.jpg

 

usb-ports.jpg

Link to comment
Share on other sites

Thanks for the advice. I will look at it, on monday, I'm not at work now, I hope this is the problem (to be sincere, I haven't even looked at the keyboard to see if there is a fn+key for switching BT on/off :)) I just received this laptop last week at work and the first I did was hackintoshing it XD.

Link to comment
Share on other sites

Thank you very much, @Jake Loand @Hervé

It's weird. Everything is up. Booting Parted Magic (Linux distro) bluetooth works.

Messages from there:

kernel drive in use: brcmfmac

...

Bus 001 Device 005: ID 0a5c:6412 Broadcom Corp (note: this is the BT ID).

...

ACPI Firmware Bug: BIOS _OSI (Linux) query ignored

[drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)

toshiba_bluetooth: Toshiba ACPI Bluetooth device driver

Some error messages, "Direct firmware load from brcm/brcmfmac4350...txt (and regulatory.db) failed with error..."

 

So, in Linux it works, it's enabled on BIOS and everywhere.

But... macOS is not detecting it. I've created SSDT-UIAC-ALL.aml, checked a lot of more things, and BT is never shown in ioreg or hackintool or DPCIManager... can it be something related to Toshiba ACPI Bluetooth implementation?

 

Thank you again,

PS I attach debug files.

debug 20200113.zip

Link to comment
Share on other sites

  • Administrators
2 hours ago, skyfly555 said:

[...]

can it be something related to Toshiba ACPI Bluetooth implementation?

[...]

No, as I suspected, it's a USB-related issue under macOS affecting the USB internal ports. I guess your definition file/table is not 100% correct.

 

By the way, your Clover folder shows only a "config copy.plist" and it cannot be properly opened with Clover Configurator. I guess it is corrupt/invalid somewhere. Can't comment on the real config.plist file (assuming there is one) but that could be the source of the problem too.

Link to comment
Share on other sites

Hello, @Hervé, and others here :)

I have created a new config.plist, and checked everything again and again.

I attach debug files (config.plist can be opened and edited with Clover Configurator now).

 

I've been trying to see the error, why BT is not detected by macOS. I've tried using another SMBIOS (now I'm using MBP13,1; I've checked using MBAir 7,2, same results).

 

I've found one thing in kernel_log.txt

 

2020-01-16 13:08:49.312987+0100 0xd7       Default     0x0                  0      0    kernel: (IOBluetoothFamily) **** [IOBluetoothFamily][SearchForTransportEventTimeOutHandler] -- 'Broadcom USB Host Controller' does not exist in IORegistry causing this missing Blutooth Controller Transport problem

 

Maybe this is the error? Can this be solved? I'm using a SSDT-UIAC-ALL.aml created following the guide that has worked for me all the other times in the past. I've used "USB3 "in HS1, HS3, HS4 (they are the 3 USB external ports of the laptop), and used internal for all the other HSs, hoping to see BT recognized in one of them.

 

Thank you one more time :)

debug_30198.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...