Jump to content
PayPal donations: [email protected] ×
rytmdoktorn

E7470, In Memory Panic Stackshot... while upgrading to 10.15.3

Recommended Posts

Installed Catalina 10.15.2 a couple of weeks ago following Jake Lo's guide.

It was working flawless.

Now that I saw that the update to 10.15.3 upgrade was like a walk in the park as long as I updated Clover, kexts and repaired permissions and rebuild cache I decided to take my chances.

So, I checked Clover, was latest version already. Updated a few kexts with the help of Kext Updater app.

(For some reason it wouldn't boot if I moved BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext. I now have BrcmFirmwareData.kext and BrcmPatchRAM3.kext in my "Other" folder.)

So, even though I have all my kexts in the EFI partition , I ran the following just in case:

 

sudo chmod -Rf 755 /L*/E*

sudo chown -Rf 0:0 /L*/E*

sudo chmod -Rf 755 /S*/L*/E*

sudo chown -Rf 0:0 /S*/L*/E*

sudo touch -f /L*/E*

sudo touch -f /S*/L*/E*

sudo kextcache -Boot -U /

 

The upgrade started and rebooted, then got stuck.

I can still get in to the 10.15.2 installation so I set the boot mode to verbose and restarted.

Now it tells me:

** In Memory Panic Stackshot Succeded ** Bytes Traced 30512 **

Share this post


Link to post
Share on other sites

Try disabling some unnecessary kexts until upgrading is done.

At Clover screen

Hit spacebar -> Block injected Kexts

Select the Folder where kext(s) resides ( Other, 10.13, 10.12…etc)

Select kext(s) to be disabled

Go back to main menu and boot with selected option

Share this post


Link to post
Share on other sites

Some unnecessary?

I tried disabling them all, no luck.

Tried disabling some random ones, no luck.

Tried the option to boot without injected kexts, no luck.

 

When booting in safe mode I get some more info on the screen if it's of any help?

 

900295427_memorypanic.thumb.jpg.25cdb9f3b0d58a6085b4f32119b25d16.jpg

Share this post


Link to post
Share on other sites

Sorry to say, still no luck.

All kexts but VirtualSMC disabled, same output.

Boot option -igfxvesa, same thing.

Will try to do a complete reinstall with 10.15.3 instead on another disk and see if that helps.

 

Will let you know in a few hours or tomorrow.

Thanks for your superb guide on installing on this computer!

I remember my first hack, it took weeks to get it working right.

 

Share this post


Link to post
Share on other sites

I tried a fresh install, same thing.

I spent countless hours yesterday trying to figure it out, nothing.

So I thought, "What is different with my setup compared to a default machine?"

Oh... the wireless card (DW1820A).

Disabled it in BIOS and... Voila!

The update installed just fine!

Enabled it again and still booting just fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...