Jump to content
PayPal donations: [email protected] ×
ABEY

Dell Precision M6800, Catalina not booting after successful install

Recommended Posts

Please help me with my Precision M6800

I had my laptop working fine with high sierra

but after trying to update to Catalina. I struggled with some configurations which I was finally able to fix and install Catalina.

for installation, I used the efi from the following topic:

 

I only added some patched acpi files and checked (drop ssdt NvdTable, ssdt cpupm, all oem ssdt) and the installation worked.

but since then I am unable to boot into my OS.

I get a panic message every time I try to boot into the system.

please help me

thanks in advance.

Share this post


Link to post
Share on other sites

Edit: Solved by updating Clover boot loader!

my only problems now are:

Wifi: this is expected and I am using ethernet cable.

Sleep Mode: I guess I need to disable usb injection or something like that.

Audio: this is the only major problem right now, only internal mic/speakers are working, headphones are not.

I remember fixing that with alc_fix by installing 2 different versions and then uninstalling them and changing some settings in clover configurator.

I tried the same clover plist settings that used to work but it didnt work. I remember deleting some system files as well, but not sure which files and the sequence of steps.

I hope someone can help me with that.

Share this post


Link to post
Share on other sites

alc_fix is to restore audio after wake

what you need is CodecCommander install to /L/E

  • Thanks 1

Share this post


Link to post
Share on other sites

Besides, changing the audio inject id in clone configurator does not seem to do anything. Even setting wrong values won't disable the audio. looks like the audio is controlled by something else. This happened in Catalina only, Unlike High Sierra.

Any suggestions would be highly appreciated.

Share this post


Link to post
Share on other sites

here is my debug file,

hope you can help me with the sleep mode as well, since deleting usbinjectall.kext didnt solve the problem.

the sleep mode does exactly like shutdown, no difference at all.

 

debug_18434.zip

Share this post


Link to post
Share on other sites

Conflict in your Config and DSDT file. Here's the fixed files.

Not sure if sleep will won't on dual graphics enabled. Will have to check with the OP.

In your kext/Other folder you have 2 USB kexts, USBPorts and USBMap. Should be one or the other, not both.

But looking at USBPorts.kext, it's not config for this system, it's hardcoded to IMac14,2.

M6800_audio.zip

  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you very much for taking a look at my config file.

I deleted the USBPorts file which I have no idea why it was there.

But the audio is still not working on headphones.

And its worth mentioning that it only shows one output device, so if I plugged the headphone, "Internal Speakers" device is gone and replaced by "headphone".

The sleep mode did not work either. Btw, I am not sure what you mean by "dual graphics enabled", because I unchecked (inject Nvidia), not sure if that is enough to disable the Nvidia card.

Thanks again

Share this post


Link to post
Share on other sites

Yes, it should auto switch from Internal to Headphone and vise versa if headphone is inserted and remove.

The kextcache log and IOReg file you attached in the debug file shows no existence of CodecCommander.kext. 

Google for the kext and install it to /Library/Extensions

Repair permissions and rebuild cache.

 

If that still doesn't work, change the layout-id in Config file under devices/properties from 12 to 18.

No, as you can see in your system information under display, you'll see both graphics. It's also showing in your IOReg file.

Try adding boot arg -wegnoegpu to Config file

If that doesn't work, we'll need to disable it via DSDT/SSDT patching

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...