Jump to content

Constant Reboot and Kernel Panic


Recommended Posts


When I rebooted my system it constantly kernel crashed and I am now can't even get into the system, the system seems to boot very normal and ask me to enter my password but when I enter my password it enters for a moment and reboots afterwords .. I've tried to user (-x) Clover argument to boot into Safe mode But with that it crashes even before loading the system.

I've attached my clover folder and a video of the system rebooting and another one when using (-x) clover boot argument. I suspect that the problem is because of HWmonitorSMC2 because I have changed one of its setting and it told me that it when be applied on the next boot ... after that I'v used the system normally for 3 hours and THEN it accrued when I rebooted :( 


Kernel Panic video: here

Clover Boot argument: here


My Specs: 

Dell 5570

Catalina 10.15.4


UHD620/Radeon 530

240Gb kingston SSD


Link to comment
Share on other sites

  • Moderators

What's the purpose of the DSDT? What patches are applied to it?

Get rid of SMCHelper.efi //paired with FakeSMC. since you're using VirtualSMC, it causes conflict

Get rid of AppleBacklightFixup.kext //Now part of WEG

Replace ACPIBatteryManager.kext with SMCBatteryManager.kext

Link to comment
Share on other sites

  • Administrators

Boot in single-user mode or boot your USB installer. One or the other should allow you to:

  • mount your Catalina partition and remove the offending kext from /L/E and rebuild your cache


  • mount your EFI partition and remove the offending kext from E/C/k/O


But I must say that your KP seems more related to that EnergyDriver kext. Isn't this installed by IntelGadget app? I'd say the kext just does not agree with Slice's HWMonitorSMC2. Maybe you should revert to the previous version of the FakeSMC-related app.

Link to comment
Share on other sites

Thanx, but the problem couldn't be solved, because I couldn't enter safe mode or Single user mode ( caused Kernel Panic) and I couldn't go to my system because of a bad kext file that caused Kernel panic, too ... So I reinstalled the OS :(

Link to comment
Share on other sites


  • Create New...