Jump to content

[OC] ProBook 6470b Big Sur battery 1% with DSDT Patch


Recommended Posts

Hi, I am currently using Big Sur on ProBook 6470b. But all guides for 6470b are outdated.

I want to make it as Vanilla as Possible. Everything works except for Tap To Click and Battery.
Big Sur has Sealed File system, so I can't really modify SLE or LE.
(except for making a Mounted Folder and then blessing it all, but it won't let me refresh the kextcache)

WIFI I am using is AR-9285, and it works fine with few kexts installed in OC
Sound is VoodooHDA, because AppleALC does not work with any IDT92HD81B1X5 layout id (3, 11, 12, 20, 28)

UPD: Applied RehabMan's Layout-3 HDEF Audio patch to my DSDT just to test it, and it worked like a charm with alcid=3 and AppleALC installed

I tried HP ProBook Generic Patch from RehabMan Repo, and applied it.
Also I installed ACPIBatteryManager.kext from RehabMan bitbucket.
But after a restart is shows 1% and that I have to service my laptop battery.

Then I start Reading those Notes in the Patch, and it says that I have to use 4530s DSDT Patches for 6x70b laptop.
But all Sources for 4530s are dead. What am I suppose to do about this?


All i need is the battery. The rest works fine.

Attaching OC EFI


Link to comment
Share on other sites

Thanks so much for your effort, but for some reason the issue still persists. Might that be because of Big Sur?

(My HP is Ivy Bridge, and I am using Haswell SMBIOS) Should I use macbookpro10,2 and set -no_compat_check?

Anyways I will try to just boot Catalina Recovery to check the battery status there.

Here is HP 6470b Original Assembled DSDT ejected using Clover F4 Key


Link to comment
Share on other sites

1366x768 but i am getting full QE/CI, so that shouldn't be a problem. But there is an optional issue (more cosmetic).

Verbose Logging looks weird and croocked, not readable. But if I turn it off, I will get a normal apple logo.

I'm just going to post it on YouTube


UPD: Set MBP10,2 but nothing changes in terms of perfomance or battery issue. Im just going to set back Haswell for better compatibility.

Link to comment
Share on other sites

Yup, Vanilla extracted using Clover installed on USB. I also extracted one using Linux Mint, compared them in hex editor and saw do difference what so ever.

The one in EFI.zip is patched tho.


UPD: I tried Catalina installer, and same as in Big Sur i am getting 1% battery.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...