Jump to content

E5540: error trying to boot Big Sur


Recommended Posts

I had pulled the drive since the one I currently have was Mojave. I thought that was an issue. I can't get the installer to work without a drive? I just wanted to get into the GUI to see if it works before swapping the drive.

Link to post
Share on other sites

Is it possible that the two bootloaders somehow are running simultaneously and causing the booting issue for the installer? The reason I ask is because while I have been trying some different configurations, I have not touched my original Clover bootloader for Mojave since I installed it. Verbose was turned off. Now when I boot Mojave it is showing the verbose. Something in one of the USB bootloader is causing changes to the Mojave installer.

Link to post
Share on other sites

Still not sure what is going on. I was able to use this EFI for a 5430 and was able to install Big Sur installed. I was even able to get this to boot and at least sound is working.

 

 

The only problem is that the system is really slow. I then over-wrote the EFI that was updated by Jake and it doesn't seem to work. If anyone is able to see what might be causing the slowness I can try to edit the 5430 and see if I can get further.

 

Thanks

 

 

Link to post
Share on other sites

I tired a E6540 EFI and while I was able to get the installer working, when it tries to go into the first bootup, the screen goes dark. I can hear Siri so it seems that it is in. I checked the config.plist and see the correct value of 0600260A which is needed for my i5 Haswell. Can someone review my config.plist in this EFI and see what could be wrong?

EFI.zip

Link to post
Share on other sites
  • Administrators

Could gain from clean-up.

  • Patched DSDT already injects all graphics properties in a XDSM method so why do you re-inject in OC config?
  • Patched DSDT already contains a PNLF device so why use a SSDT-9 (strange name by the way) to inject PNLF?
  • Patched DSDT contains an EC device (for PNP0C09) so why inject the SSDT-EC?
  • Don't use FakePCIID_Intel_HDMI_Audio; it's deprecated and you already inject Lilu + AppleALC.
  • No need for AICPUPM patch on a Haswell platform; that patch is for Sandy Bridge and Ivy Bridge platforms only.
  • Using OCC app, reselect MacBookPro11,1 profile to regenerate SMBIOS.

You probably should try without your patched DSDT, I think it clashes with the rest of your OC setup.

Link to post
Share on other sites

Thanks for the help. Not sure if I got everything you mentioned (I don't know a lot about this). 

 

When I booted up I am not getting "Couldn't alloc class AppleIntelpchseriesahci" 

 

Attached is my updated EFI

 

Edit: I tried the patched CtlnaAHCIPort.kext but still getting the same error message.

 

E5540_2020_02_28-1.zip

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...