Jump to content

Dell Latitude 5510: can Big Sur be installed on it?


Recommended Posts

Hi all,

 

did anybody succeed in stallating Catalina or Big Sur on an Dell Latitude 5510 (i5-10310U, Intel UHD graphics)?

I tried the EFI folder from this post:

I know that it is for a Precision.

Was worth a try.

 

The installation stopped right after the boot.

 

Any suggestion how to successful install?

 

TIA

.d

Link to post
Share on other sites
  • Replies 40
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

OK, hope this helps.

 

dell latitude 5510 (2020):
- Intel Core i5-10310U 10th generation
- Integrated Intel UHD graphics
- Chipset Comet Lake
- 16 GB Memory, will be upgraded to 32, if mac os install is possible
- NVMe Drive 512 GB
- Realtek ALC3204 Audio
- Intel Wi-Fi AX201
- Intel Ethernet-NIC I219LM

 

Thx

.d

Link to post
Share on other sites

Hi,

 

I have a very similar Latitude 5410 laptop with an i7-10610U running Big Sur with OpenCore.

 

Specs:

  • Intel i7-10610U processor
  • Intel UHD 620 graphics
  • 16GB 3200Mhz DDR4 Memory
  • 256GB NVMe Drive
  • Realtek ALC3204 Audio
  • Intel Wi-Fi AX201
  • Intel I219L NIC

Here's what I have working so far:

  • Keyboard works with backlight, volume hotkeys, backlight toggle hotkey
  • Internal speakers working
  • Wifi, Airport, Bluetooth
  • Battery level seems right

I found a random Github repo of some guy's working Latitude 5400: Github. I copied his config.plist DeviceProperties section. It's for an i5-8265U so I have no idea why it works but it does. I have hardware acceleration working! Attaching updated config.plist. If anyone can give me a hand with the trackpad, I'd appreciate it but other than that it's all working! Brightness hotkeys for the display as well, if anybody has any experience with those.

config.plist.zip

 

I haven't been able to get the trackpad working, linux shows it as an I2C-HID device but the Voodoo kext isn't working for me either. Any help would be greatly appreciated! Attaching my EFI folder. @denkteich if you end up getting it installed my EFI should at least help with sound, wifi and ethernet, my specs for those are almost identical to yours.

 

EFI.7z

Link to post
Share on other sites

@Jake Lo I made a second post but it seems it didn't save for some reason, I actually got my iGPU working. I copied some guy's config from Github out of desperation, he had a comet lake processor and to my surprise it just worked. Doubt it's helpful to you @denkteich but I'm attaching my updated EFI. And I'm gonna try those files when I get a chance, definitely hoping Sinetek-rtsx.kext will get my SD card reader working, didn't even know it was a thing.

 

Edit: Just realized I don't have HDMI out with this config

 

EFI.7z

Link to post
Share on other sites

@Jake Lo I got around to adding the files you posted. 

 

  • Trackpad works now, however it's laggy and when you first touch it the cursor jumps to a random spot on the screen
  • Trackpad buttons don't work, strangely when I left click and drag on the desktop it starts to drag out a selection square but disappears after about a second, none of the 5 buttons work for anything else though
  • SD card reader works 😀

EFI.7z

Link to post
Share on other sites
  • Moderators

Did you have tab to drag enabled?

Trackpad buttons not working is known when using VoodooI2C.

What 5 buttons?

Do you have full graphics aceleration with my files?

Does HDMI video / Audio work?

Sleep/ Wake?

Fn keys for Brightness work?

Can you post an IOReg using IORegistryExplorer.app v2.1?

Link to post
Share on other sites

By the 5 buttons, I mean the left/right click and then there's 3 above the track pad, left/right click and middle mouse button. I do have full graphics acceleration at this point, however no HDMI out at all. Sleep/Wake seems to be working fine. Fn keys for brightness aren't doing anything. And I'm not sure what you mean by tab to drag? I have 3-finger drag enabled but it doesn't seem to work, hard to tell though since my cursor jumps all over the place when using track pad. Two-finger scroll works though. Here's my IOReg. Thank you so much for all your help btw.

IOReg.zip

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...