Jump to content

E6430: Backlight unstable on Big Sur installer


Recommended Posts

Hi everyone am trying to install big sur on my laptop but currently using Mojave which is working perfectly with the exception of touchpad and Atheros AR9485WB-EG Wireless card.


I followed this  and downloaded EFI files for OC bootloader.

i generated my SSDT.aml as instructed in the post and replaced it.

The main problem is after OC verbrose screen, the backlight will go off immediately on the apple logo. The temporal workaround to bring the backlight back is "fn + arrow up" but it will go off randomly again and if i don't do that quickly the laptop will go to sleep and i will have restart the installer again.


What i have tried so far;

regenerated my own SSDT.aml

tried latest whatevergreen and lilu kext

tried flashing back and forth dell BIOS version

Tried recommended bios settings from this site

Tried Herve's EFI file in this post and touchpad is not working

All didn't solve big sur backlight abnormality 


So my question is, is there a way to fix the backlight issue with a kext or drivers ?

If am to stuck with mojave, is there a way to use whatever is making my touchpad working when booting big sur using EFI from here

Is there something am missing?

Is there working EFI available for my model?

Note: Mojave works with any bios version i flash regardless of warning to flash A12


Thanks everyone.



Here is my Specs


Dell Latitude E6430
Processor Name:                        Intel Core i5-3340M
CPU Brand Name:                      Intel(R) Core(TM) i5-3340M CPU @ 2.70GHz
Total Memory Size:                    12 GBytes

Video Chipset:                            Intel HD Graphics 4000
Video Chipset Codename:        Ivy Bridge GT2
Video Memory:                           2112 MBytes

Screen Resolution
1366 x 768                                 309 x 174 mm, Pixel Clock 76.75 MHz
1366 x 768                                 309 x 174 mm, Pixel Clock 50.80 MHz

Drive:                                          Seagate ST750LM022 750GB 5400 RPM (Have SSD Backup drive)

Audio Adapter:                           Intel Panther Point PCH - High Definition Audio Controller [C1]

Network Card:                           Atheros AR9485WB-EG Wireless Network Adapter
Bluetooth interface:                  Foxconn / Hon Hai Qualcomm Atheros AR3012 Bluetooth(R) Adapter

BIOS ver:                                    Currently on A20


Link to comment
Share on other sites

  • Administrators

Backlight should work OOB with the right settings in place: Capri framebuffer usual patching + SSDT-PNLF.

TouchPad should also work OOB with the VoodooPS2Controller available in my E6230 guides; the kext works 100% in all E6x30 models of the range. Maybe yours is faulty or possibly disconnected; check that out.

Latest BIOS are Ok to use for sure as long as you apply the FBMem patch that reduces memory from 16MB to 8MB (glitchy graphics otherwise).

  • Like 1
Link to comment
Share on other sites

Thanks for the reply, how do i apply "Capri framebuffer + SSDT-PNLF" to my efi folder to solve the issue.?

Do i need to generate SSDT-PNLF for my model as i did with SSDT-PM.aml?

I don't mind much about touchpad as i use external mouse most of the time.

Glad to know bios version is not that much of a problem as am free to upgrade back to A23.

I know i sounds lame as am kind of new to hackintosh world.

Link to comment
Share on other sites

  • Administrators

ACPI tables:

  • You already have the SSDT-PNLF in your OC ACPI folder, so all is covered.
  • You need to remove SSDT-PLUG though and disable it in your OC config.

Graphics/Capri framebuffer properties:

  • All suitable/necessary properties are already injected in your patched DSDT (see _DSM Method under IGPU device).


  • Remove VoodooHDA and replace with AppleALC (its' a Lilu plugin). Audio will then work with alcid 12.
  • You shouldn't use USBInjectAll alongside USBPorts. Latter is usually generated having initially booted with the former. So try without USBInjectAll to begin with.


I invite you to consult my E6230 guides for details of the kexts I've used and what they do. Versioning is also detailed in case you need to update those that may be old.


It's important that you get NVRAM working as this will ensure active/selected screen brightness is retained throughout reboots or sleep/wake cycles.

  • Thanks 1
Link to comment
Share on other sites

hey sorry for late reply, i was reading to equip myself with some basic as am very dumb.


1. i removed SSDT-PLUG from the acpi

2. replace VoodooHDA with latest AppleALC from here

3. i update the config with Plist Editor Pro


and disabled VoodooHDA.

4.Since am good on Capri something, i left it untouched

Lastly i am confused of this "It's important that you get NVRAM working as this will ensure active/selected screen brightness is retained throughout reboots or sleep/wake cycles." How do i make the nvram working?


Link to comment
Share on other sites

thanks mate, but i have decided to give up after reading, testing and failing for days on all kinds of tutorials and EFI folders. At a point my hdd and modular bay stopped working.

My laptop wont boot anymore with those things mentioned above connected and i flash BIOS versions again, finally downgrading it to A03 saved my ass.

Am gonna cool down for awhile and wait for someone's already working EFI folder for my model or someone generously prepare one for me.

I understand i am a total noob to this that's why everything seems difficult and always failing.

Even catalina won't install.

Thank you man for your help.

NB: i spent several days on dortania without success😄

Link to comment
Share on other sites

  • Moderators


Give this a try.

Files are defaulted for the following configuration




If your display resolution is lower, then use Config-LoRes and rename it as Config

I also include DSDT-A23 for BIOS version A23, you'll just need to rename it in the Config file

If you have different CPU other than the ones I included, i5-3340M and i5-3320M, then you could use SSDTPrGen.sh to generate your own

Place it in ACPI, rename it to whatever you like ...maybe SSDT-PM.aml? But make sure to rename it in the Config file as mine is defaulted to i5-3340M.aml

Upgrade your BIOS to A24 or A23 to use my files otherwise you probably get the same automatic sleep right after boot.

I see you have A20, I could probably patch that for you, but I'll need the vanilla DSDT exported from your system.

Good luck



  • Thanks 1
Link to comment
Share on other sites

@Jake Lo

I tried it by making the following changes


A23 bios and 1366x768 resolution

so i did the following in propertree on windows


Deleted these from ACPI folder
1. DSDT-A24.aml
2. SSDT-i5-3320M.aml
3. SSDT-i7-3520M.aml
4. ssdtPRGen.sh


and i updated the your original config.plist file not the LoRe.plist with changes made above
1. ACPI>ADD    changed DSDT-A24.aml to DSDT-A23.aml
2. left SSDT-i5-3340M.aml as it is same as mine


I didn't succeed in booting to the installer interface.

Had some errors which i screenshot for debugging and to track down the error.

I am attaching them in their order of occurrences and a log from OC.


After failure on bios A23 i upgrade it A24 and reversed the changes made earlier but i faced the same error.

But i noticed ACPI>DELETE you have "Drop CpuPm" and "Drop Cpu0Ist" set to "false"


Anyway i love the bootloader theme🙂


00:000 00:000 AAPL: #[EB|LOG:INIT] 2021-04-29T11:28:09
00:071 00:071 AAPL: #[EB|VERSION] <"bootbase.efi 495.80.3~11 (Official), built 2020-12-21T21:13:03-0800">
00:145 00:073 AAPL: #[EB|BUILD] <"BUILD-INFO[306]:{"DisplayName":"bootbase.efi","DisplayVersion":"495.80.3~11","RecordUuid":"9D1BBDDB-A7A6-4B24-8D67-9F605C922885","BuildTime":"2020-12-21T21:13:03-0800","ProjectName":"eficrap (chameleon, stolen and rebranded)","ProductName":"bootbase.efi","SourceVersion":"495.80.3","BuildVersion":"11","BuildConfiguration":"Release","BuildType":"Official"}">
00:218 00:073 AAPL: #[EB|CFG:DEV] r2 0x0 0x0
00:292 00:073 AAPL: #[EB|H:IS] 0
00:324 00:031 AAPL: #[EB|WL:MODE] 0
00:394 00:069 AAPL: #[EB|CFG:ARG] boot-save-log 0x0000000000000002 (0x0000000000000002 < 0xFFFFFFFFFFFFFFFF) default
00:467 00:073 AAPL: #[EB|CFG:ARG] wake-save-log 0x0000000000000002 (0x0000000000000002 < 0x0000000000000002) default
00:540 00:073 AAPL: #[EB|CFG:ARG] console       0x0000000000000001 (0x0000000000000001 < 0x0000000000000001) default
00:614 00:073 AAPL: #[EB|CFG:ARG] serial        0x0000000000000000 (0x0000000000000000 < 0x0000000000000000) default
00:645 00:031 AAPL: #[EB|CFG:ARG] embed-log-dt  0x0000000000000000 (0x0000000000000000 < 0x0000000000000000) default
00:715 00:069 AAPL: #[EB|CFG:ARG] timestamps    0x0000000000000000 (0x0000000000000000 < 0xFFFFFFFFFFFFFFFF) default
00:788 00:072 AAPL: #[EB|CFG:ARG] log-level     0x0000000000000001 (0x0000000000000001 & 0x0000000000000021) default
00:861 00:073 AAPL: #[EB|CFG:ARG] breakpoint    0x0000000000000000 (0x0000000000000000 & 0x0000000000000000) default
00:935 00:073 AAPL: #[EB|CFG:ARG] kc-read-size  0x0000000000100000 (0x0000000000100000 < 0xFFFFFFFFFFFFFFFF) default
01:008 00:073 AAPL: #[EB|H:IS] 0
01:040 00:031 AAPL: #[EB|WL] 0 0 0x01 0x01   0 0x00
01:110 00:069 AAPL: #[EB|BRD:NV] Mac-189A3D4F975D5FFC
01:183 00:073 AAPL: #[EB.B.IEP|!] Err(0xE) <- BS.LocP 8ECE08D8-A6D4-430B-A7B0-2DF318E7884A
01:256 00:073 AAPL: #[EB|WL] 0 0 0x01 0x01   2 0x00
01:330 00:073 AAPL: #[EB.BST.IDT|+]
01:403 00:073 AAPL: #[EB.BST.IDT|-]
01:435 00:031 AAPL: #[EB|WL] 0 0 0x01 0x01   3 0x00
01:505 00:070 AAPL: #[EB|WL] 0 0 0x01 0x01   4 0x00
01:578 00:073 AAPL: #[EB|BRD:NV] Mac-189A3D4F975D5FFC
01:652 00:073 AAPL: #[EB|WL] 0 0 0x01 0x01   5 0x00
01:725 00:072 AAPL: #[EB.H.CHK|BM] 0x0000000000000000
01:756 00:031 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.GV boot-signature 7C436110-AB2A-4BBB-A880-FE41995C9F82
01:826 00:069 AAPL: #[EB|WL] 0 0 0x01 0x01  23 0x0E
01:900 00:073 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.GV boot-image-key 7C436110-AB2A-4BBB-A880-FE41995C9F82
01:940 00:040 AAPL: #[EB|WL] 0 0 0x01 0x01  24 0x0E
02:052 00:111 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.GV boot-image 7C436110-AB2A-4BBB-A880-FE41995C9F82
02:313 00:261 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.SV- boot-signature 7C436110-AB2A-4BBB-A880-FE41995C9F82
02:629 00:315 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.SV- boot-image-key 7C436110-AB2A-4BBB-A880-FE41995C9F82
02:713 00:084 AAPL: #[EB.H.LV|!] Err(0xE) <- RT.SV- boot-image 7C436110-AB2A-4BBB-A880-FE41995C9F82
02:794 00:080 AAPL: #[EB|H:NOT]
02:894 00:100 AAPL: #[EB|SB:P] 0x0
02:966 00:071 AAPL: #[EB|LIMG:DP] Acpi(PNP0A03,0)/Pci(1D|0)/Usb(1, 0)/Usb(3, 0)/HD(Part2,Sig0006C16A)
03:039 00:072 AAPL: #[EB|LIMG:FP] \System\Library\CoreServices\boot.efi
03:109 00:070 AAPL: #[EB|LIMG:OPT] 
03:140 00:030 AAPL: #[EB|RPS] 0 0 0
03:214 00:073 AAPL: #[EB.OPT.LXF|F] <"\\System\\Library\\CoreServices\\com.apple.Boot.plist">
03:284 00:070 AAPL: #[EB.LD.LF|IN] 0 1 <"\\System\\Library\\CoreServices\\com.apple.Boot.plist"> <"0">
03:356 00:072 AAPL: #[EB.LD.OFS|OPEN!] Err(0xE) <"\\System\\Library\\CoreServices\\com.apple.Boot.plist">
03:429 00:073 AAPL: #[EB.OPT.LXF|LF!] Err(0xE)
03:502 00:073 AAPL: #[EB.OPT.LXF|F] <"Library\\Preferences\\SystemConfiguration\\com.apple.Boot.plist">
03:534 00:031 AAPL: #[EB.LD.LF|IN] 0 1 <"Library\\Preferences\\SystemConfiguration\\com.apple.Boot.plist"> <"0">
03:611 00:076 AAPL: #[EB|KF] <"root-dmg=file:///BaseSystem/BaseSystem.dmg">
03:683 00:072 AAPL: #[EB|MBA:CL] <"">
03:756 00:072 AAPL: #[EB|MBA:NV] <"-v keepsyms=1 -f alcid=12 -igfxnohdmi  darkwake=0 -no_compat_check slide=67 ">
03:829 00:073 AAPL: #[EB|MBA:KF] <"root-dmg=file:///BaseSystem/BaseSystem.dmg">
03:861 00:031 AAPL: #[EB|MBA:OUT] <"-v keepsyms=1 -f alcid=12 -igfxnohdmi darkwake=0 -no_compat_check slide=67  root-dmg=file:///BaseSystem/BaseSystem.dmg">
03:931 00:070 AAPL: #[EB|LOG:VERBOSE] 2021-04-29T11:28:13
04:005 00:073 AAPL: #[EB.CSR.S|VAR] 0x00000040
04:078 00:073 AAPL: #[EB|OPT:BM] 0x2
04:151 00:073 AAPL: #[EB|B:VAw]
04:225 00:073 AAPL: #[EB|P:CPR] N
04:257 00:031 AAPL: #[EB|P:MPI] N
04:327 00:069 AAPL: #[EB|P:BPI] N
04:400 00:073 AAPL: #[EB|KMR] 294166528
04:474 00:073 AAPL: #[EB.CS.CSKSD|+]
04:505 00:031 AAPL: #[EB.CS.CSKSD|!] Err(0xE) <- RT.GV boot-info-payload 8D63D4FE-BD3C-4AAD-881D-86FD974BC1DF
04:575 00:069 AAPL: #[EB.G.CS|-?] Ok(0)
04:651 00:076 AAPL: #[EB.LD.LF|IN] 0 1 <"<null string>"> <"1">
04:869 00:217 AAPL: #[EB.B.SBS|SZ] 739896
04:946 00:077 AAPL: #[EB|B:SHA] <6c4c18c09ba51a04539131ed525a219a7a175c00>
05:020 00:073 AAPL: #[EB.WL.PWLFNV|!] Err(0xE) <- RT.GV wake-failure 7C436110-AB2A-4BBB-A880-FE41995C9F82
05:052 00:032 AAPL: #[EB.WL.DT|!] Err(0xE) <- EB.WL.PWLFNV
05:123 00:071 AAPL: #[EB.WL.PWLFRTC|NONE]
05:197 00:073 AAPL: #[EB.WL.DT|!] Err(0xE) <- EB.WL.PWLFRTC
05:270 00:073 AAPL: #[EB.LD.LKC|D] <"System\Library\KernelCollections\BootKernelExtensions.kc.development">
05:344 00:074 AAPL: #[EB.LD.OFS|OPEN!] Err(0xE) <"System\\Library\\KernelCollections\\BootKernelExtensions.kc.development">
05:376 00:032 AAPL: #[EB.LD.LKC|R.2] <"System\Library\KernelCollections\BootKernelExtensions.kc">
18:287 12:911 AAPL: #[EB.LD.LKFS|-?] Ok(0)
18:362 00:074 AAPL: #[EB.LD.LKC|-?] Ok(0)
18:436 00:074 AAPL: #[EB|FWFM] 0x00000000FF1FFF7F
18:509 00:073 AAPL: #[EB|FWFT] 0x00000000EB0FF577
18:541 00:031 AAPL: #[EB|BST:REV1]
18:610 00:069 AAPL: #[EB|CSR:OUT] 0x00000040
18:687 00:076 AAPL: #[EB.BST.FBS|+]
18:760 00:072 AAPL: #[EB.BST.FBS|ADSZ] 0
18:833 00:073 AAPL: #[EB.BST.FBS|KSSZ] 0
18:906 00:073 AAPL: #[EB|SB:SBGMFNS] x86legacyap.im4m
18:980 00:073 AAPL: #[EB|RH:PF] usr\standalone\OS.dmg.root_hash
19:054 00:073 AAPL: #[EB|RH:MF] <"usr\\standalone\\OS.dmg.root_hash.x86legacyap.im4m">
19:086 00:031 AAPL: #[EB.LD.LF|IN] 0 1 <"usr\\standalone\\OS.dmg.root_hash"> <"0">
19:156 00:070 AAPL: #[EB.LD.OFS|OPEN!] Err(0xE) <"usr\\standalone\\OS.dmg.root_hash">
19:229 00:073 AAPL: #[EB.RH.LRH|P!] Err(0xE) <- EB.LD.LF
19:303 00:073 AAPL: #[EB.BST.FBS|!] Err(0xE) <- EB.RH.LRH
19:335 00:031 AAPL: #[EB.B.WFDW|!WF] Err(0xE) 0
19:406 00:071 AAPL: #[EB|LOG:DT] 2021-04-29T11:28:28
19:489 00:082 AAPL: #[EB|LOG:EXITBS:START] 2021-04-29T11:28:29


  • Like 1
Link to comment
Share on other sites

  • Create New...