Jump to content

D620 (nVidia): Kernel Panic with Lion


EVH
 Share

Recommended Posts

Update to my previous thread about installing SL on my D620.

 

Since I was unable to get the Snow Leopard installer to go beyond 4 lines on verbose mode and I was able to run the Lion installer with rather more success I decided to install Lion. Only thing was I had a Core Duo so I upgraded the CPU and got the Lion pack with My hack 3 .3.1. I am however getting a FakeSMC fatal error (see pics).

 

Bios version is a10

 

I have so far:

 

Added the following flags at boot:

-v but when that didn't work then

 

-v -f and when that didn't work then

-v -f -x

 

Toggled

===> Virtualization on and off

===> Speed step

===> hard drive performance or bypass options

 

Disabled

-Wifi (is there a hardware button to achieve that also?)

-Bluetooth

-Printer port

-Serial ports

But Fake SMC has to do with the CPU right? (I'm a forever newbie at this)

 

Lastly, I did apply the extra folder in MyHack.

 

I'm attaching some pics. Any ideas?

 

20210513_110952_Burst03.jpg

20210513_111551.jpg

 

 

Thanks in advance for your input

Here's a more complete kernel panic pic at the very end where it hangs.

20210513_114707.jpg

Link to comment
Share on other sites

Bios version is a10. I don't remember have seen an AHCI option under sata to my recollection but will check.

 

You mean I should add that to the MyHack Extra folder? I did follow the instructions in the sense of having downloaded the correct pack which was the D620_NV110m_10.7.5_Pack for Lion installer. Shouldn't that pack be there? Should I resort to the old EDP installer method?

Link to comment
Share on other sites

  • Administrators

No AHCI option for the Latitude D620, the disk can only be run in IDE mode. As for EDP, it was abandoned many years ago and it's no longer relevant. The bootpacks I posted cater for everything and all is fully tuned.

 

Your issue has nothing to do with FakeSMC, which is unrelated to CPU. FakeSMC does what its name implies: it fakes the SMC of an Apple Mac.

 

What you're experiencing is a KP on CPU power management, which is unexpected because you seem to have applied our bootpack properly and I can see in your screenshot that VoodooTSCSync kext is loaded. SpeedStep should be enabled in BIOS (or system will run like a dead dog). You could always try and add NullCPUPowerMangement kext to the Extra/Extensions folder as a temporary workaround until you suss out the problem. You'll need to re-run MyHack->myFix afterwards of course.

 

One thing I find very odd, though, is your BIOS screenshot which shows: Dual Core Present = no. You can't run Lion without a dual core 64bit Core2Duo CPU at minimum. What CPU model did you go for when you upgraded? Merom T7400?

 

Make sure you set your BIOS settings as per the recommendations specified in our dedicated our thread on the matter. It's available at the top of this very D6x0 forum section. On top of SpeedStep, Multi Core Support must be enabled!

Link to comment
Share on other sites

Thanks Herve for your detailed response.

 

The processor I've got was this: SL9SE Intel Core 2 Duo T7400 2.16GHz 4MB 667MHz Processor CPU. I did toggle everything I could on the BIOS and I probably tried running the laptop without multicore support.

 

Re: NullCPUPowerManagement, do we have a Kext library? I'm still sort of getting acquainted with the site. And thank you again bud. We'll definitely give all your suggestions a shot. Will look for the BIOS settings recommendations at once too (I don't know yet where they are but I sure should be able to find it)

Link to comment
Share on other sites

  • Administrators

No kext library, no; just Google for it though you'll probably find it with a Search on the forum and in many old packs; probably is in some of the packs I posted for the old D series too.

Re: BIOS settings, I just told you where you'll find the thread... :huh:

Link to comment
Share on other sites

SUCCESS CREATING THE USB INSTALLER

Saw a very old thread here on the D620 and read something crucial about the three types of wifi cards that were used in assembling these laptops. The BIOS would show three types of wireless and if INTEL wireless was showing it had to be disabled in the BIOS or the installer would not work. Mine was INTEL, however my recollection is that I tried all of these things unsuccessfully until last night.

 

Gave it yet another try with an old Macbook running 6.8.0, downloaded MyHack 3.3.1 from here and was finally able to create a Lion installer that reached the installer screen !!!

 

MyHack hung at the end of the creation of the USB during the "caches part". It never told me the process completed successfully. It did ask to be patient at this stage so I left it for over 6 hours and nothing, so I pressed "cance" and then pressed "quit". Then I started MyHack again to install the "extra" folder and MyHack hung again at the end. This time I didn't cancel hours later but kind of left it a few minutes and interrupted the process again. I didn't think it was going to workbecause it never told me it succeeded but... IT DID!

 

Haven't run the install to a drive yet but I believe I now have a good USB Lion install drive for D620 nvidia model with its bootpacks. I feel almost tempted to upload it somewhere to save someone the grief.

 

This old operating system, (even Leopard and Snow Leopard) on these older machines works INCREDIBLE for Logic 9 (music creation program for those unfamiliar with it). You can hook it up to a $20 MIDI keyboard and a stereo or a decent set of speakers and you now you have an entire suite of professional sounds at your disposal and no hassle! I'm sure I could still use this systems 20 years from today on an old $20 garage sale beginner's keyboard. Amazing. Let's keep these computers away from the land field and recycle.

Link to comment
Share on other sites

  • Administrators

The old laptops are totally obsolete today but they did run Mac OS X extremely well; I remember fondly the days when I had my D620 and D630 and, God!, did SL feel fast on those! But they've had it by now (especially the flawed nVidia models) for most basic stuff.

 

NB: as per our recent news update on the matter, Lion and Mountain Lion are available off Apple for free so no need for pirate repositories.

Link to comment
Share on other sites

Thanks for the links Hervé! Bookmarked them!

 

These machines have plenty of life in them. Sure you can't watch youtuve 4k in them but you can play with a bunch of very capable software and a ton of hardware for audio that was in the hundreds of dollars is now only obsolete because most companies have decided not to update drivers. It's deliberate planned obsolescence, but the hardware that was available for these machines is now being sold for pennies and can be coupled with one of these older computers and you can keep making music. People paid hundreds of dollars for Mac computers not faster than these D620s and paid hundreds of dollars for audio hardware and recorded albums with them. You can today have it all for less than $200. Perfect for teaching audio to a student, you name it. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...