Jump to content

HP Pavilion x360: Synaptics TrackPad and audio not working


Recommended Posts

  • Replies 37
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Your touchpad is a synaptics. Try replace acidanthera's VoodooPS2Controller with Rehabman's

I'll connect the battery and test. Although right now I have enough to be able to navigate. Maybe in a few days there will be a new post to work on the screen. I did not know that MacOS could be

Posted Images

  • Moderators

You added SSDT-HPET but you left out the patches for the IRQ's, there are 3 of them. Here, I added them and include SSDT-XOSI.aml + patch.

Add the SSDT* to the ACPI folder, replace the Config file. 

If still no audio, change alcid=13 and test again. Post new IOReg file if needed.

By the way, I disabled SMCDellSensor.kext, obviously it's for Dell system only.

x360_audio.zip

Link to post
Share on other sites
  • Moderators

AppleALC still not loading, make sure VoodooHDA is totally removed. It disables AppleALC from loading.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...