Jump to content

Latitude 7310: Journey to Catalina and Big Sur


Recommended Posts

I've decided to move from my pre-existing Latitude 7490 builds to a new workstation: Latitude 7310, aiming for OpenCore v0.7.0 on Catalina. Workstation specs on my signature below.


And I basically can't even get the installer to boot successfully. There's actually not much on the internet for this machine, and I couldn't get the one posted on this forum to work. 


So I started back from scratch based on Dortania's guide. 


Hoping I can make some headway with the gurus here, as we have done so in the past. 


Attaching my EFI folder, and boot logs from OpenCore as well. I removed IntelBluetooth kext since it was taking up 15mb alone.  


Appreciate any help possible!

EFI + OC Logs.zip

Link to comment
Share on other sites

  • Administrators

i7-10610U is Comet Lake (not Whiskey Lake) so I don't think you're injecting the correct properties for your CML iGPU fake id and FB layout; according to the WEG user manual and the Dortania OC documentation, you should be using:

  • ig-platform-id 0x3E9B0000
  • device-id 0x3E9B


  • Like 1
Link to comment
Share on other sites

Thanks for checking in @Hervé. I tried your suggestion as below: 




System unfortunately still kernel panics while trying to boot into installer. Here is a video I managed to record, since screen is small I didn't think you could see the error before it panics. You may need to download the video to see it in full resolution. 


Also reattaching the latest config.plist here


Link to comment
Share on other sites

Thanks for the help Jake. Unfortunately no dice, device still kernel panics. Here's the latest OC log, and recording of the panic here


Could you let me know what you noticed about my config file? I'm wondering if there is a bios setting that might be causing it, but I have followed Herve's 7490 guide. 


Wondering what else I can try, may be trim down on the kexts and drivers to bare minimum and work from there...


Link to comment
Share on other sites

  • Administrators

I would not compare the settings of 8th gen Kaby Lake Refresh 7490 with those of 10th gen Comet Lake 7310. By all means, do post the list of setting you use because we don't necessarily know what the 7310 offers (I certainly don't). After you make changes to your OC config, you clear NVRAM, right? Which version of Catalina are you trying to install by the way? From memory, Comet Lake and Ice Lake are only supported from 10.15.3 or 10.15.4. Check it out in the Software section.

Link to comment
Share on other sites

Hi @Jake Lo and @Hervé


I'm happy to report that I have made progress. Jake, after reviewing your config file, and noticing your mmio whitelist addition, I began troubleshooting my open core settings, and here's what seems to have worked for me. 


for Comet Lake, Dortania guide advises default setting as below. This configuration however did not work for me.




While troubleshooting with dortania again, this section seemed most relevant: Stuck on [EB|#LOG:EXITBS:START]


where it clarifies the following: 



I can confirm that my particular model supports MAT, but its one of those odd models that also breaks even when it supports MATs. When I noticed Jake's mmio whitelist attempt, I thought I might as well give the first option a try, which is boot with old firmware quirk combo. 


By some miracle, that worked, and I am able to boot into installer, and have now successfully installed Catalina. These are my current quirk settings, where I follow the set-up recommended for older firmwares



Obviously you would notice by now that I am clueless as to what these all mean, and why it worked. Since I hit a brick wall, I decided to try anything. 


Jake, Herve, if you could shed some light for my understanding and learning, that would be great!


Next post, on to fixing some issues...

First boot I realised that there was no graphics acceleration, 7mb issue. I keep forgetting how Device ID and frame buffer settings should be done (the bit flip is confusing and I still don't quite understand). 


Anyway, this is finally the correct setting that enables graphics acceleration: 



I can also confirm from my bios setup that I already have 64mb preallocated, so I am wondering if I can remove the other frame buffer patches for fbmem and stolenmem, or if I should leave it?


Second issue. Now that I managed to get graphics acceleration working, there is some odd behaviour for the display, where brightness is set to the dimmest point where you can barely see anything. But after around 7 to 10 minutes, it suddenly goes to full brightness. Any idea how I could fix this. 


The reason why this is odd to me is that when I didn't have graphics acceleration due to my FB settings, I somehow still had full brightness control, including working brightness keys from the shortcut. 


Some other broken bits, which I haven't fully had the time to understand yet why, and how to fix. If anyone could help point me in the right direction, that would be great: 

- Trackpad does not work. the cursor moves very little, if at all

- Wifi doesn't seem to connect to 5Ghz networks. It can detect it, but can't connect

- Even with sinetek kext included, SD card reader doesn't seem to work (on my 7490 it works perfectly)

- USB C can display out to 1440p at 59ghz. I would like to be able to set it to output 4K 60hz. I wonder if that is possible


I attach ioreg output and latest config file. Any help I would very much appreciate. 

ioreg & config plist.zip

Link to comment
Share on other sites

  • Create New...