Jump to content

Latitude 7310 - Journey to Catalina


Recommended Posts

  • Administrators

Those values are the expected ones but you could always tried the other values that have been posted/mentioned for other various Dell models. Note that you would need to engage in complex technical analysis if you wanted to verify the ACPI codes returned by the Fn-Fxx key combinations for brightness control. Former Hackintosh expert Rehabman detailed the process on one of his GitHub repos.

 

Alternatively:

  • revert to the original SSDT-BRT6 table  (with IGPU device for iGPU)
  • rename GFX0 to IGPU in SSDT-PNLF-CFL table
  • add renaming of GFX0 to IGPU in your OC config

and test again.

 

I would also suggest you test switching from SSDT-PNLF-CFL to SSDT-PNLF table, the one applicable to models of previous generations.

Link to comment
Share on other sites

Hi everyone, @Hervé @Jake Lo, thanks very much for the help so far. 

 

Been test driving my current build as my daily, and while touchpad and screenbrightness hotkeys still do not work well, I need some help to troubleshoot 3 new problems that I've discovered. 

 

1) While attempting to fix audio jack issues, I tried the codec commander + audio jack fix (in usr/bin). My audio used to work through the speakers, but now it does not work at all anymore, no output devices are detected.   

image.png.a2f39d9f5a0f5ba5700155244b770580.png

 

2) Running Intel Wifi, while convenient, is not ideal. As a workaround, I purchased a satechi USB C dock, which has an ethernet port. However, ethernet is not being detected correct, or is unable to be assigned an IP. The rest of the ports on the drive seem to work as expected (USB, SD Card reader). Its just the ethernet port that is not able to connect to internet. Note that the 7310 latitude does not have a built in ethernet port

image.png.ecf2419c41776359ec4d88760942cb9a.png

3) I am wondering if thunderbolt ports are working on my device (while troubleshooting problem 2 above. In system profile, it seems to note that there are no thunderbolt drivers. I am aware of the need to connect thunderbolt devices pre-boot in order for it to work, and hotplugging does not work well in MacOS. With the above satechi thunderbolt dock, is there a driver/kext that I am missing in my setup?

image.png.cc66f5866df8b53a2cfd27edb1d56d74.png

 

Attached latest EFI and IOReg extracts, hopeful that it helps with the troubleshooting

 

As usual, appreciate all your guidance and wisdom.

 

Hackintel.ioreg

Link to comment
Share on other sites

Wow... thanks for the fast response @Jake Lo. You never fail to amaze me... with you pack: 
- OC updated to 0.7.1

- Audio issues fixed

- Brightness hotkeys fixed

- SD Card reader upgraded with new and improved kext... now it shows up in System Profiler as well :) My previous attempt at this ended in kernel panic...

- Touchpad stopped working - odd issue with this model (and my previous 7490 as well). Had to revert to older versions of the Voodoo kext to get some touchpad functionality working again

 

I'm taking time to unpack more of your changes so I can learn what made the differences. 

 

In the mean time, any advice on what to do to enable LAN connectivity and Thunderbolt 3?

Link to comment
Share on other sites

  • Moderators

Hmm, could be VoodooInput.kext that's making the difference because I switch it to the latest VoodooPS2's Input.kext in the Config file instead of what you had before which was Input.kext from VoodooI2C (older version).

You could try putting back the latest VoodooPS2 but switch to VoodooI2C's Input.kext to confirm.

The ethernet on the dock, do you know what model or brand is it? Maybe need to add a kext if existed?

For thunderbolt, give this SSDT a try, just add it to the Config file. As you know, it'll only work on boot if it works at all, but not hot-plugging.

Post a new IOReg file after adding this SSDT file

 

SSDT-TYPEC.aml.zip

Link to comment
Share on other sites

Hey Jake, 

- Trackpad fixed, you were spot on on VoodooI2C Input.kext being the cause

- Added SSDT-TYPEC.aml in, attached IOREG profile

- Ethernet USBC Hub, interestingly I found a few things, not sure what to make of it. It seems to be detected correctly... I checked its hardware on windows as well: 

image.thumb.png.545425db62099d403516192a46170505.png

 

 

telegram-cloud-photo-size-5-6330130054947908794-x.jpg.8f374708d6a54dcc02a773602cba02ec.jpgtelegram-cloud-photo-size-5-6330130054947908795-x.jpg.28092a2b82f7315936510370bd65199b.jpg

 

Thanks again for your help. I really appreciate it. 

 

 

Hackintel.zip

Link to comment
Share on other sites

Thanks for the help and verification, after some experimenting, and looking through the documentations for ITLWM kext, I realised that the kext was spoofing the wifi card as a LAN NIC, and hence kept masking the IP for lan connections. 

After turning wifi off, and unplugging and replugging the usb C doc, lan connectivity was restored, with full speeds. This workaround is acceptable for now. 

 

@Jake Lo I noted in your original OC0.7.1 config file, you excluded SSDT-PNLF-CFL, and included SSDT-BCKM instead. Are they both required? or should I just stick with BCKM only?

 

Thanks!

Link to comment
Share on other sites

Ah ic. Noted, I'll remove PNLF from the list of ACPI patches. Brightness seems to work fully (I can increase and decrease all steps from min to max)

 

I realised that my dock is actually a USB C dock, instead of a thunderbolt dock, that's probably why system profiler reports that no Thunderbolt driver is found. Once I get a thunderbolt dock, I'll hook it up and report back.

 

Now that most key issues have been resolved on this model. There is only 1 item left to fix, that is to find the right patches for VoodooI2C to work on interrupt mode instead of polling mode.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...