Jump to content

Precision 7530 EFI Issues


Recommended Posts

Hi all mates,


I've been trying for several days and I still haven't even managed to successfully run the MacOs installer, I'm stuck in the boot process.


I have tried to use the EFI files from our colleague lulugh -- https://github.com/lulu-gh/Dell-Precision-E7530-Prototype-OpenCore/tree/11.5-legacy , but I can't get it to work on any of the versions he offers (11.2 , 11.5 , 12b4).


I have also tried with the EFI files from nnkn https://github.com/nnkn/hackintosh-dell-precision-7540-oc , more of the same, in this case I even read the dmg to get to the, installer so I can't access the boot process.


Can someone guide me or help me to get an EFI compatible with my computer?


My hardware:

CPU: i7 8850H 

iGPU: Coffee Lake UHD 630

dGPU: nVidia Quadro P3200

MLB: Precision 7530, BIOS version 1.16.1

RAM: 2x32Gb

Wifi: Intel AC 9260

Ethernet: Intel I219-LM+

4K Screen


Thank you very much =D



Link to comment
Share on other sites

9 hours ago, Baio77 said:

Debug EFI 0.7.2.zip
Use this EFI Debug, extract useful information for those who want to help you have a Hack, extract ACPI Origin from the bios + various other information about the system in general, once extracted the files placed here Log.txt and Sysreport folder

Hi Baio, thanks for your quick response.


Here are the log.txt and the Sysresport folder, in order to give us more info.


9 hours ago, Hervé said:

Could be a issue with the BIOS not being properly configured for macOS. Try and check that with those who hacked their 7530. Ideally, a dedicated thread on the matter would be great for the benefits of everyone.

Thanks Hervé for your response, i will check with the authors of the githubs and i will collect some info from the opencore website.


Any recomendations for the Bios Setup? 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...