Jump to content

[Solved] E7470: Intel HD 520 and 4K output


Recommended Posts



I did report this in the past and i never found a workaround let a lone a solution.


Basically, Windows can do [email protected] in HDMI (it's a 1.4 HDMI), and [email protected] through the miniDP 1.2. MacOS maxes at [email protected] on both ports.


I did get curious about this and stumbled on the WhateverGreen patching for Intel iGPU's. Here i am, having tried virtually a Dr Strange amount of times of entries, to no avail.


This is my latest Device Properties for it. I have to say there's virtually no difference in performance from Jake Lo's original package.







Another entry that seems to cause issues is the hdmi20-enable, which causes a well known blank/black screen. I guess that should be very normal considering we have HDMI 1.4.


WhateverGreen patching guide give us these values to play around:



0x19160000 (mobile, 3 connectors)


ID: 19160000, STOLEN: 34 MB, FBMEM: 21 MB, VRAM: 1536 MB, Flags: 0x0000090F
TOTAL STOLEN: 56 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 124 MB, MAX OVERALL: 125 MB (131608576 bytes)
GPU Name: Intel HD Graphics 520 (0x19168086)
Model Name(s): 
Camellia: Disabled
Mobile: 1, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[0] busID: 0x00, pipe: 8, type: 0x00000002, flags: 0x00000098 - LVDS
[1] busID: 0x05, pipe: 9, type: 0x00000400, flags: 0x00000187 - DP
[2] busID: 0x04, pipe: 10, type: 0x00000400, flags: 0x00000187 - DP
00000800 02000000 98000000
01050900 00040000 87010000
02040A00 00040000 87010000




Link to comment
Share on other sites

  • Moderators

I'm happy to say I was able to enable 4K on my E7470 quite easily. I didn't have it on my guide previously because I just recently got one.

Here are the steps:

Going off of the my bootpack version OC 0.7.0

1) Add modGrubShell.efi to /EFI/OC/Tools

2) In the Config file, under Misc/Tools, add modGrubShell.efi to the list

3) In Config file, under DeviceProperties/Add/PciRoot(0x0)/Pci(0x2,0x0), Disable or comment out 



4) Save and Reboot

5) At OC picker, if you don't see the new ModGrubShell, press the spacebar to review and select it

6) Once booted to the Grub Shell, enter the following 2 commands

    setup_var 0x432 0x3


7) This will bring you back to the OC picker

😎 Select MacOS to continue booting 

You should now be able to connect to HDMI or miniDP with 4K resolution. With HDMI, you can only connect @ 30Hz

I don't have (2) 4K displays, so can't test if you can have both running at the same time.

/!\ Important, make sure to enter those commands exactly. Anything else might prevent system from booting. 



Link to comment
Share on other sites

@Jake Lo Hero of the week mate. Thanks a lot.


It makes sense, the fbmem and stolenmem ones are when you cant go around having the DVMT changes. No need to use them when you can switch them.


What is very weird is that i did these values, i even checked them up to confirm. Your modified grub must be the difference maker, and this explains why unlocking CFG never actually worked for me and i had to use the quirks for it.


Much appreciated sir. I cannot believe i am writing this from a virtually complete hackintosh.

Link to comment
Share on other sites

  • Administrators

Can confirm this mod brings native support for 4K on the E7270 too.


I'm using Clover so a simple cancellation of the fbmem/stolenmem iGPU properties injection from the Options menu was sufficient for testing.




Here's [email protected] out of 4K-capable miniDP-to-HDMI adapter (non 4K-capable miniDP adapters or cables only support FHD 1920x1080 res):






Here's [email protected] out of HDMI:





NB: Ignore the SwitchResX stuff, it's leftover from previous attempts to get 4K running.

Link to comment
Share on other sites

Indeed. I've lost the selection of 1440p, but that might be due to my spoiled up device properties that i played around with from WhateverGreen's patching instructions. Scaling now does not have the list of resolutions, but the choice of "how big you want your text" (with a resolution under it). Seems only 1440p is missing. No deal breaker.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...