Jump to content

Mountain Lion - Dell Latitude E6420 Intel HD3000


Alejandro
 Share

Recommended Posts

Hi all.

 

First let me thank you all for this amazing forum. I'm an owner of an Imac since 2010, and Mac OSX is my favorite OS. Now my office give a laptop with windows and I really want to install Mac OSX. The laptop is a E6420 with an Intel Graphic Card HD3000.

 

So, I start with mountain lion. I use unifail to create my install usb. It works perfect, the installation runs without problems. After I need to restart with the unifail USB and select the harddisk an then It will finish the installation process. Note: I use a USB keyboard, I don't know if is really need it but just in case, use it.

 

The video looks good with full resolution 1366x768.

 

Now, I have a few problems.

 

- The OSX start only if I use the unifail USB.

- No wifi.

- No sound.

 

Those are the big problems right now.

 

If I try to start without the unifail USB, It looks like there is no Bootloader in the harddrive. Does anyone knows how can I fix this?

 

For the WIFI and Sound I will try some kext, but I would like to fix the bootloader first.

 

Any ideas?

 

Thanks in advance.

Link to comment
Share on other sites

Ok, now I'm trying to install chameleon with a myHack thumb drive. But It doesn't start. I also try to start the usb with the boot param mach_kernel -v -f and the only thing that I see is this:

 

BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or directory

 

Is there any other way to install chameleon?

 

I will continue my research.

 

I made it to install chameleon but I't doesn't works. I still getting the boot0 error. Also tried installing chimera (chameleon, stolen and rebranded) from multifail but is the same result boot0 :(

 

 

Any idea

 

Best regards

 

Alejandro

Link to comment
Share on other sites

Ok, I manage to repair the boot using the instructions in the following page

 

http://www.macbreaker.com/2012/02/hackintosh-boot0-error.html

 

I use chameleon instead of chimera (chameleon, stolen and rebranded).

 

But now, I have a kernel panic. I boot with the flags mach_kernel -v -f and the problem seems to be

 

com.apple.driver.AppleIntelCPUPowerManagement

 

EDIT: I manage to extract the DSDT using ubuntu live cd 12.04. I attached to the post.

 

Any ideas?

 

Thanks in advance.

 

Best regards

e6420dsdt.aml.zip

Link to comment
Share on other sites

Ok, I'm having big progress here :D

 

First you are going to need a USB Keyboard, just in case.

 

I use multifail 4.6.1, and install the options

 

-System Utilities -> Repair Permissions

-Drivers & Bootloaders -> Kexts & Enablers -> Audio -> Universal -> VoodooHDA 0.2.7.3

-Drivers & Bootloaders -> Kexts & Enablers -> Network -> hnak’s AppleIntelE1000e Ethernet

-Drivers & Bootloaders -> Kexts & Enablers -> Misellaneous -> FakeSMC, NullCPUPowerManagement, PS/2 Keyboard/Mice and Trackpads

-Customization -> Boot Options -> 64-bit Apple Boot Screen

-Customization -> System Definitions -> Macbook Pro -> MacbookPro 8.1

-Customization -> Themes -> tonycrap86 Classic

 

Now is booting without any usb.

 

Things to do:

 

Fix WIFI

Fix sleep

Fix Trackpad

Fix WebCam

Fix VGA Output

Fix HDMI Output (Not tested)

Fix Battery Indicator

Fix Memory Card Reader

 

UPDATE 1

 

To fix the battery indicator y use the Kextbeast from

 

http://www.tonycrapx86.com/downloads.php?do=cat&id=3

 

And download the kext from:

 

http://forum.voodooprojects.org/index.php?topic=1092.0

 

Put the kext in the desktop and run the application.

 

Still no luck with the WIFI. I'm gona need a little help please.

 

 

UPDATE 2:

 

Ok, after some problems I reinstall everything but found some interesting things.

 

First, don't use multifail. I saw that everytime that I boot from the unifail USB drive, the trackpad works perfect, until I install multifail. So what I do is:

 

-Boot with the unifail USB and run the installation.

-Open a terminal

-Copy the Extra folder from the USB to the MAC OSX disk.

-And to fix the boot0 error, do:

-umount /dev/disk0s2 (be carefull, make sure that the osx installation disk is disk0s2, if not, put the correct device diskXsY)

-dd if=/Volumen/unifail USB/usr/standalone/i386/boot1h of=/dev/disk0s2 (same as before, check which is your device)

 

Reboot and done.

 

Working without USB and trackpad fully functional.

 

NOTE: I don't think this affect but this installation was using a backup disk. But I don't think this update the kext. So that is why a said not use multifail.

 

UPDATE 3:

 

The webcam is working, I didn`t do anything. I left the facetime application open and eventually the webcam image popup. It`s look bad and jumpy, but when I call somebody the other person see me perfectly.

 

Bad news, I added the read memory card issue. It's doesn't recognize the memory reader. Any ideas?

Link to comment
Share on other sites

Ouch.. Well, I'm going to buy a PCI Card to fix this issue :P

 

The other big issue is the trackpad. Is kind of annoy to depend from a usb mouse. Any ideas?

 

Another thing is the webcam. It works with skype or even to take the picture for the profile user. But when I open Photo Booth the light turns on but the camera don't work. Same with facetime.

 

I think that now I have a very good system, but what is left is very little :P

 

So, if anyone want to experiments with me, welcome.

Link to comment
Share on other sites

I have a 6520 with Nvidia graphics and the non-intel wireless (realtek I think it is). I am having trouble getting the imbedded wireless to work still. Any ideas?

I will be getting a 6420 next week, I will be setting that up for my Son. Not sure if it has Intel wireless or not. But I do know it has Intel graphics, so what kext works for that?

I did my install for 10.7.2 with iFail L2 and selected VooDooHDA 2.7.3 audio drivers I believe. Not sure what else. ITs been a few weeks. I should have taken notes. :-(

I will be trying all of this on a 6320 soon too (that is for my Ex-wife and daughter). So any input on the Intel video adapter and the wireless can and would be helpful. If you have a link to the compatible wireless card to order if I need it for the 6420 that would also be helpful. I seem to remember that the 6320 also has the realtek wireless card. I just can't figure out which kext I actually need.

iMacinTosh - 12,2, core i5 Quad 2400, i7-3770K Quad core, 16 32 Gigs Crucial 1600 memory, PNY Nvidia 430 GT 2G DDR5, SOYO 20 LG 24 HD Monitor, HDs in an Antec 300 CM 922 HAF case

Link to comment
Share on other sites

Hey guys...

 

Some updates...

 

Bronxteck the macam did not work :S

 

It's a kind of weird what is happening, because the webcam works for skype, and also to take my pictore for the OSX profile. But for facetime or PhotoBooth doesn't works. But thank you so much for your help.

 

For the wireless I bought a cheap usb card. NETIS, It's works, the only thing is that It's use his wireless setup network program, but at least now I have internet access :P

 

Now I have another problem, I installed LinuxMint (for work purpose) and It has been impossible to made chameleon to recognize the linux partition. I have tried almost everything, creating boot partition, installed grub in / or /boot . Nothing seems to works. I missing something but I can't figure it out what is.

 

Any help?

 

And using Chameleon 2.1.

 

Thanks in advance.

 

Cya

Link to comment
Share on other sites

 Share

×
×
  • Create New...