Jump to content

Dell E7280: 99% working!


Recommended Posts

Dell 7280 Laptop Hackintosh 

CPU: I7-6600u
GPU: Intel HD 520
Ram: 16gb DDR4
OS: macOS BigSur/Windows 10/Linux Mint
SMBIOS: MacBookPro 13,1
Boot: OC


What works:

  • SD
  • Multi Touch Trackpad
  • Webcam
  • Microphone
  • Backlight keyboard
  • USB-C out (HDMI/Audio and USB)
  • Wifi (Intel AX200 Wifi 6)
  • BT (Magic Trackpad and Magic mouse)
  • Sleep (but kills the usb ports on the hub and sometimes won’t turn back on)

What doesn’t work/doesn't work well:

  • I have to unplug the HDMI on the laptop once the system is booted and re-plug it in for the main display to work.
  • The screen backlight controls randomly stopped working but I remapped Shift+Up/Down and that seemed to have fixed it.

Extra Info: 

  • I keep the laptop docked via a USB-C dongle with an HDMI, 3 x USB 3.0 and 1 x USB 2.0. and automatically turns on when AC power is connected. (via dongle) I’ve tried to map various Dell WD15 and TB16 docks but they suck.
  • I get about 2.5 hours of use at 100% CPU when testing and 4-5 hours normal use in macOS.

I'd love to hear any advice or tweaks needed for my config file, or maybe if anyone has any ideas on how to fix the hotplug monitor issue. 




Hackbook’s MacBook Pro.ioreg

Link to comment
Share on other sites

  • Administrators

I'm not certain you need to change pipe value or inject flags for your iGPU connectors. Injecting/faking the iGPU's own device id is, of course, of no use. I also believe injecting enable-hdmi20 to be inapplicable on platforms that only support HDMI 1.4...



All I do on my Skylake i7-6600U/HD520 E7270 is inject HDMI type (00080000) to con1 and use boot arg igfxonln=1. I have adjusted DVMT pre-allocated memory through Grub shell-based BIOS data mod. Try that and see if these settings makes a difference. I detailed my observed behaviour with HDMI in my E7270 guides.


I believe all you need to inject is:

AAPL,ig-platform-id        00001619        DATA
AAPL,slot-name             Built-in        STRING
framebuffer-patch-enable   1               NUMBER
framebuffer-fbmem          00009000        DATA     -> not needed if you change DVMT pre-alloc mem to 96MB through Grubshell
framebuffer-stolenmem      00003001        DATA     -> not needed if you change DVMT pre-alloc mem to 96MB through Grubshell
framebuffer-con1-enable    1               NUMBER
framebuffer-con1-type      00080000        DATA


Link to comment
Share on other sites

  • Create New...