Jump to content

Dell XPS 9370: no graphics acceleration on UHD620


tazorro
 Share

Recommended Posts

Hi, I managed to install Macos Catalina on my XPS9370 with i5-8250U and get everything working except the uhd 620 4K which sees at 31mb. I followed dortina's guide for Kaby Lake r to set UHD but nothing. I tried a thousand settings but nothing. If anyone could help me.

EFI00.zip

Link to comment
Share on other sites

  • Administrators

You're injecting incorrect properties for KBL R UHD620 iGPU:

iGPU_settings.jpg

 

iGPU device id 0x87C0 is for Amber Lake iGPUs, not Kaby Lake Refresh...

 

See the WhateverGreen user manual:

https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md

 

For Kaby Lake R platform with UHD620 graphics, you should be using:

  • KBL framebuffer 0x591B0000
  • iGPU device id 0x5916

 

On my Kaby Lake R Latitude 7490 with UHD620 graphics, I was successfully using:

  • KBL framebuffer 0x59160000
  • iGPU device id 0x5916

as described in my associated guide available here and only patched 2nd connector con1 for HDMI type (I don't fully understand why you inject properties for all 3 connectors con0, con1 and con2).

Link to comment
Share on other sites

  • Administrators

Your system's not crashing; just failing to initialise graphics due to incorrect settings.

 

If DVMT is already preset to 64MB in BIOS, there's no need for you to patch framebuffer memory and DVMT in your config so get rid of those patches.

You must however fake iGPU id 0x5916.

For the rest, experiment with the various mobile KBL framebuffers if the recommended ones don't appear to work. Also make sure you use MacBook Pro15,2 SMBIOS.

 

The following properties injection should suffice:

AAPL,ig-platform-id        00001659        DATA     // or maybe 00001B59
device-id                  16590000        DATA
framebuffer-con1-enable    01000000        DATA
framebuffer-con1-type      00080000        DATA
hda-gfx                    onboard-1       STRING

 

Just in case, you may want to replace the disable-external-gpu property by boot arg -wegnoegpu.

 

Also make sure Optimus is enabled in BIOS or you'd only run on the nVidia dGPU which will be unsupported.

Link to comment
Share on other sites

Hi, after endless attempts I was able to have graphics acceleration using these parameters:

ig-platform-id 00001B59 DATA
device-id 12590000 DATA
enable-hdmi20 01000000 DATA

The system runs well without uncertainty. I decided to try to upgrade to Big Sur but eventually get the prohibition symbol. Some advice?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...