Jump to content

E6440: trackpad not working


Recommended Posts

Hi everyone!


New member here in search of answer. I've been around hackintosh for a while now but I never really understood the process. I just followed guides made by awesome people and was lucky enough to get working systems 3 or 4 times now. For the past week I have been trying to install Catalina on this laptop (Dell Latitude E6440) and I am close to success except for the trackpad that is not working. I've found a couple of topics here about this but I cannot fix mine, maybe I just don't understand the process. I replaced my VoodooPS2Controller a couple of times with various ones but I still get a non working trackpad. Again, I think I missed some steps because I just replace the kext in Library/Extensions of my booting hard drive. I also wanted to include my EFI file here but it's too big even when zipped, if anyone have a suggestion on how I could include it...


Oh and to anyone who would want to help me with this, thank you very much in advance!

Link to comment
Share on other sites

  • Replies 20
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Moderators

If you have Intel wifi / BT kext in the kexts folder, leave them out. Then you should be able to compress it to the require size.

Also, in the EFI folder, just include the boot and OC or Clover folder, leave out any other boot folder

Link to comment
Share on other sites

  • Moderators

You have way too much kextS, duplicate kexts and unnecessary kexts.

KNOW YOUR HARDWARE is one important aspect to building a clean install

For ethernet, you only need IntelMausi.kext, get rid of the rest..ie Realtek*, SmallTree*, Atheros*, AppleIntelE1000* ETC.

Get rid of all the FakePCIID*

Get rid of XHCI*

Get rid of NullCPU* unless you don't care for power management

Get rid of Sata*

Get rid of GenericUSB*

Get rid of the Backup folder //no idea what's in there and how big

Get rid of AHCI*


Have a backup incase it won't boot after removing all those kexts but I don't see that happening.

Link to comment
Share on other sites

Ok, got rid of the scrap, booted right up.


I know my hardware, it's the whole kexts programming, config plist that I don't understand. This EFI was built by someone else and was supposed to be working, guaranteed. I now realized it's not so great but it's the best I have right now. 


I have replaced the wifi card in the laptop with an Atheros one because I read that the intel one is not compatible so I did not remove that kext. This is another thing that is not working with the trackpad.


With the unnecessary kexts removed I can now upload my kexts folder from clover :)


And just in case this is my config plist but at that pointt I'm afraid to show it... ;)



Link to comment
Share on other sites

  • Moderators

Get rid of Whatvergreen, you have 2 versions

Get rid of USBInjectAll, you have 2 versions

Get rid of AppleGB, AtherosE2200Ethernet, AtherosL1cEthernet, IntelMausiEthernet

The Atheros kexts are for Ethernet not wireless, so it's useless.


Can't help you with Atheros Wifi since you didn't specify the full model. Look here for supported devices /unsupported device for patches and kexts

Some support for Intel Wireless now, what model do you have? See here for kexts, go with the stable version

For touchpad, replace your current VoodooPS2Controller.kext with this one



Link to comment
Share on other sites

Ok, you guys are fast ;)


Removed all the kexts you guys suggested and rebooted straight in, That is good!


For the Atheros card: AR5B22 half mini PCIe (here's the link: https://www.amazon.ca/gp/product/B0875QJK83/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1 )


For the original wifi card: Intel Centrino Ultimate-N 6300, model # 633ANHMW


I then copied the Voodoo kext supplied by Jake Lo, rebooted and still no trackpad.


Then I moved to Hervé's post, installed ALPS kext but forgot to remove the other Voodoo and rebooted to a circle with diagonal bar (sorry I don't know the name of that sign) on Catalina drive. I did try the recovery drive and it seems to be reinstalling right now from apple. 

Funny thing, after rebooting from the recovery partition, the trackpad is working...


Link to comment
Share on other sites

With your experience, would you suggest the atheros or intel?

ok, so I took the chance of booting into Catalina from my SSD one more time and it booted right up.


No trackpad, no wifi.


I didn't knew there was an option to install kexts to Library/Extensions, I really am a newbie at this and really don't understand the whole process. Since the beginning I just modify the kext folder from the EFI of the Catalina SSD.


What should I do next?




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...