Jump to content

Dell latitude 5501: no HDMI output


thawri
 Share

Recommended Posts

Hello everyone.

My Dell latitude 5501 (i7 9850H, igpu only uhd 630 )working perfectly and running monterey 12.4.

but HDMI not working and can not use my monitor.

 

initially I use EFI posted by @Baio77 here.

 

I try multiple methods to fix this.
tried dortania guides for GPU patching and try a lot of BusIDs.

try multiple smbios and boot args.

trying for about 3 days for fixing this problem. But there was no success.

at last, I Adjust DVMT using this method.

now mac Os boot without framebuffer-fbmem and framebuffer-stolenmem but HDMI not responding yet.

I thought by set DVMT Pre-allocated to 64M and DVMT Total GFX MEM to Max, problem must be solved. but it seems there is another problem there and I can not find that.

my monitor is 2K and I have working with it by another hackintosh.

Can you help me to fix this problem, please?

thanks in advance.

 

@Jake Lo @Hervé @Baio77

dell latitude 5501 EFI.zip dell latitude 5501 ioreg.zip

Link to comment
Share on other sites

My HDMI is plugged in but not in IORegisteryExplore not showing that.
please see screen shot.

only display0 in [email protected] with connector type <02 00 00 00> which is my laptop display.

 

 

Screen Shot 2022-08-20 at 09.06.45.png

[email protected] connector type is <00 08 00 00> , HDMI

[email protected] is <00 04 00 00> i.e Display port.

there is no display port on laptop. maybe it is type c.
if I purchase a type-c to HDMI adapter, Is there any hope?

or I must buy type-c to DP?

Link to comment
Share on other sites

yes, only UHD 630 IGPU.

then I must find proper bus id?
I test atleast this:

01000900 00080000 87010000

02060A00 00080000 87010000

----------------------------

01000900 00080000 C7010000

02050A00 00080000 C7010000

----------------------------

for all busIDs from 1 to 6
and another try by set this flags in boot args: igfxonln=1 agdpmod=vit9696
 

Link to comment
Share on other sites

  • Administrators

And the HDMI output in question is that of an HDMI port on the laptop, not of an HDMI adapter connected to a USB-c, right?

 

9th gen. Coffee Lake i7-9850H is fitted with UHD630 iGPU carrying id 0x3E9B; that's natively supported in all recent macOS versions. As stated in the Whatevergreen User Manual, you should be using CFL framebuffer 0x3EA50009.

ID: 3EA50009, STOLEN: 57 MB, FBMEM: 0 bytes, VRAM: 1536 MB, Flags: 0x00830B0A
TOTAL STOLEN: 58 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 172 MB, MAX OVERALL: 173 MB (181940224 bytes)
Model name: Intel HD Graphics CFL CRB
Camellia: CamelliaV3 (3), Freq: 0 Hz, FreqMax: 0 Hz
Mobile: 1, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[0] busId: 0x00, pipe: 8, type: 0x00000002, flags: 0x00000098 - ConnectorLVDS
[1] busId: 0x05, pipe: 9, type: 0x00000400, flags: 0x000001C7 - ConnectorDP
[2] busId: 0x04, pipe: 10, type: 0x00000400, flags: 0x000001C7 - ConnectorDP
00000800 02000000 98000000
01050900 00040000 C7010000
02040A00 00040000 C7010000

 

Having set DVMT to 64MB in BIOS, you no longer need to patch FBmem ans StolenMem any more, indeed.

HDMI output usually registers against connector con1. I would have kept the index unmodified... And you only need to patch the connector type (to 00080000) to gain HDMI audio. The video output should still work with default DP type.

 

Try with the default framebuffer settings (i.e no connector patching) and experiment with other SMBIOS like MBP15,x/MBP16,x for instance.

  • Like 1
Link to comment
Share on other sites

yes HDMI port on the laptop.

 

what do you mean " The video output should still work with default DP type"?

 

is this default framebuffer settings you talked about?:

1.jpg.08e75ad61bea8d08d00275166bfc25f2.jpg

 

 

and if testing multiple SMBIOS with default framebuffer not worked, I must test multiple BusId for "01000900 00080000 C7010000" in con1?

i.e:

01010900 00080000 C7010000

01020900 00080000 C7010000

01030900 00080000 C7010000

...

in framebuffer-con1-alldata?

 

2.jpg.defc80bdcf419765dc076d3c07d77f37.jpg

 

@Hervé

Link to comment
Share on other sites

  • Administrators

Why do you inject iGPU device id 0x3EA5? Yours is natively support so no need for that property which can be removed.

As I said, remove all connector patching to begin with and experiment with different SMBIOS instead, starting with MBP15,x.

 

By default framebuffer settings, I mean the obvious: the parameters that comedy default with the selected framebuffer, i.e. no patching through property injection.

Bascially, at this stage, all you should have is this:

AAPL,ig-platform-id        0900A53E        DATA

 

Link to comment
Share on other sites

@Hervé

I have not succeeded yet.

I test these SMBIOS by default framebuffer:

MBP 15,1-2-3  and 16,1-2-3-4

after that test multiple framebuffer for con1 (and some case con2) for some SMBIOS specially MBP 16,1- 16,4, 15,2.

 

I must set enable-backlight-registers-fix to 1 in PciRoot(0x0)/Pci(0x2,0x0), otherwise after booting laptop screen also is black and I must wait about 2-3 minutes to turn it on.

in this situation, macOS is booted and I hear the wrong password sound or if I enter the password and hit enter, after the screen is turned on I see am logged in.

 

Doesn't this give you a clue?

I would be very grateful if you could help me

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...