Jump to content

Dell Vostro 1500


Recommended Posts

I have successfully, for the most part, got a Dell 760 Optiplex working pretty darn good on Mountain Lion and am now going to give it a whirl on a Dell Vostro 1500 laptop. Here are the specs, basically the loaded Vostro.


Processor / Chipset: CPU Intel Core 2 Duo T5270 / 1.4 GHz

64-bit Computing

Front Side Bus: 800.0 MHz

Chipset Mobile Intel GM965 Express

Memory: 4gig DDR2 SDRAM (Dual In Line Memory Module 2GB, 667, 256X64, 8K, 200)

Interface: Serial ATA-150

Display: Type 15.4 in Max Resolution 1280 x 800 ( WXGA ) Color Support 18-bit color

Graphics Processor: Intel Graphics Media Accelerator X3100

Memory Allocation Technology Dynamic Video Memory Technology 4.0

Codec STAC9205

Compliant Standards High Definition Audio

Wireless 802.11g Dell Wireless 1395

Network Interface 10/100 Ethernet


...The rest is on the Dell website (Core 2 Duo).


I have tried initially a few times to get ML going on it, but keep running into panics, and not sure how to see what it causing them (a log somewhere?)


I was hoping someone might know or have something similiar working and might have a kext package I could try. I did get it up and running vanilla, but once I add the ACPIPlatform, it seems to really have issues.


I am willing to start over if I can get someone to tell me what I need to do again. Start over with a newly created MyHack USB? I am not sure just what is supposed to be in the EXTRA directory by default.


Well, Id like to get this going...I will keep posting my findings.

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

Another oddball. When I set SATA Operation = AHCI in BIOS, I cannot see the hard drive when in Disk Utility. Set in back to ATA and I can see it again. Like the exact opposite from what I would expect. With either setting however, watching the verbose logging shows a very long wait at the ACPI: System State [s0 S1 S2 S3 S4 S5] (S3) entry. When in the ATA setting, it took about 5 minutes to get past this, but it eventually did. I partitioned the drive GUID and started the install. It is SO slow, but eventually finished like 2 hours later...must be a slow USB.

Link to comment
Share on other sites

I know I am not getting a whole lot of help here, but worth a shot...I am booting -v - f and am stumped to figure out what these messages mean in the bootup verbose logs...


AppleSMBusPCI failed to get ACPI path for provider

AppleBlueToothHCI failed to get ACPI path form provider

IOBluetoothHCIControllerSetConfigState calling register service (***it hangs here for a very long time)

ACPI_SMC_PlatformPlugin - timeout

ACPI_SMC_PlatformPlugin: failed to locate SMC driver

ACPI_SMC_PlatformPlugin - Warning LPC device initialization failed: C-State power management not initialized

AppleBlueToothHCIControllerUSBTransport[configPM] [ERROR] waited 30 seconds and still did not get the commandWakeUP() notification

IOBluetoothHCIControllerSetConfigState calling register service


I got so close, with Lion up and running, WIFI working, but almost system hang within 10 seconds. I know so many people have got just 10.7 working, but I am working hard on getting MountainLion working.


Please any help getting this working would be so so very much appreciated.

Link to comment
Share on other sites

  • Administrators

shut off bluetooth from bios to see if it helps get a bit further. seems very similar to d630 spec wise maybe try using that boot pack without a dsdt use your own dsdt if you have it. you also might want to look at the dsdt edits done on the gma x3100 d630 and compare it to your own edits. but x3100 graphics and ml do not get along by the way.

Link to comment
Share on other sites

Thank you so very much for your reply. When you say "dsdt", I have heard of it, I just don't know what or how to use it. I only really know the /Extra and the myHack way (osxlatitude and EDP). I do see a dsdt.aml file from the files I got from a similar system, but don't know anything about it. Perhaps you would assist? I will give LogMeIn access into my system while it is running in safe mode perfectly.

Link to comment
Share on other sites

I have been at the point where safe mode boots perfect and also runs perfect, but when I try to boot up normal, in vervose mode I see a recycle over and over and think it has something to do with authentication, as far as I could tell from scouring the net, because I see a file com.apple.coreservices.appleid.authentication and com.logmein.logmeinguiagentatlogin among about 5 other com.apple.launchdb... files, and it just repeats over and over, about every 15 seconds. Could I send a syslog file? Just confused at this point.

Link to comment
Share on other sites

Definitely ML. I got it working on 2 other Dell's (Optiplex 755 and 760). I actually got ML up and running but it would freeze on me within 10 seconds...so very close. Now, if Safe Mode works perfect, I just have to figure out the kext files I think, I just don't know which one or what to look for with the recycling of the authentication (my previous post).

Link to comment
Share on other sites

  • Administrators

To be honest, don't bother.


You can't get graphics acceleration with the Intel X3100 (no 64bit kext + higher graphics requirements needed on ML, like for OpenGL) and those who tried to run ML without acceleration on D630 eventually gave up. Without a supported GPU, graphics performance is bad (I'm told displaying things as trivial as menu bar items now calls on the GPU) as everything has to rely on the CPU itself. On top of that, your Vostro does not possess the most performing C2D (2Mo cache, 1.4GHz dry.gif ) ... It'd be more sensible to try and run it with Lion. I think you really are wasting your time.


But, should you wish to persist... re:DSDT table, you could try to build your own. Have a look at Olarila web site. You can extract a table from Windows (if you can still run Windows on that Vostro) and patch it before you compile it.


Try and post your BIOS settings, there could be something to modify.


Which bootloader do you use?

Link to comment
Share on other sites

  • Create New...