Jump to content

SL 64bit on D620s


Jrm
 Share

Recommended Posts

I have SL 10.6.8 running on D620Nvidia in 32bit mode. This is a 32bit only D620. I would like to get it running on another D620Nvidia 64-bit machine in 64bit mode. Is this supported? If so, can I clone the first D620(32bit) to the D620(64bit) or is a clean installed required. I have already tried the cloning method and it doesn't seem to work with -force64 flag, but maybe some other tweaks need to be done. ? As I write this I'm trying a clean install on the D620Nvidia 64bit machine.

 

Thanks

Link to comment
Share on other sites

  • Administrators

you use the arch=x86_64 flag not force 64. if i remember the d620 nvidia uses nvhal40 kext which i think is 32bit only. as for the drive... cloning /swapping should work fine as long as you have edp built for the machine your testing before swapping.

Link to comment
Share on other sites

Thanks for the quick reply....

 

I have the clean install of SL 10.6.0 on the D620Nvidia64bit system and I still cannot get it to run the 64 bit kernel. I have tried "-arch=x86_64" and system profiler --> Software shows that I'm not using 64bit. Has anyone gotten SL to run in 64bit mode on a D620? I have searched the forums, but I have not found any anwsers there.

Link to comment
Share on other sites

Back to testing... It is loading sometrhing close to nvhal40. I think it is nvdanv40hal. The boot log lines are flashing up quickly and it doesn't seem to be the same each time. I tried to use Wait=yes and that doesn't pause the boot log.

 

i have read conflicting statements about the default boot mode of SL being 64bit. My system boots fine w/o arch=x86_64. It appears to be booting 32bit by default. I;m using current (3.1.2) Myhack chameleon as described here.

 

anymore thoughts?

 

Thanks

Link to comment
Share on other sites

  • Administrators

Have a look at the following post:

http://forum.osxlati...der-64bit-mode/

 

'never got the D620 nVidia to boot SL in 64bit mode (it has adequate CPU). The D630 X3100, however, certainly seemed to do so with Lion since I was booting with default graphics (no 64bit kext for Intel Crestline graphics = default graphics).

 

I've not tried it yet, but I guess there's a good chance you'd boot the D620 in 64bit mode under Lion.

Link to comment
Share on other sites

Thanks Herve ... I had just stumbled across that topic minutes ago. Is the bottom line that D620Vidia64bit machine can only run SL in 32 bit mode? I can live with that but it didn't seem obvious. Since I'm new to the Hackintosh scene I thought it was some mistake I was making doing the install.

Link to comment
Share on other sites

 Share

×
×
  • Create New...