Jump to content

Dell 7280 - problem with install with shared OC EFI folders


Recommended Posts



I'm still newbie with running Hackintosh. I have Dell 7280 (i7-7300u, 16GB RAM, 1920x1080, Toshiba SATA M.2). I found some OpenCore EFI folders but I can't properly boot MacOS installer.


First I've tried @Akerbeltz14 folder with Sonoma installer from this topic: 



Installer ends on this screen, then computer is rebooted:




Then I've tried @takobaba folder with Ventura from GitHub: https://github.com/takobaba/EFI-Opencore-Dell-7280


Installer loads and ends with following information, and then laptop reboots:



Maybe someone can deduce something from the above regarding corrections to the OC configuration?


The third I found is @Lorys89 shared with GitHub: https://github.com/Lorys89/DELL_LATITUDE_7280


I didn't tested it yet. Do I need to make described modifications in modGRUBShell.efi? @takobaba and @Akerbeltz14 does not mention about that.


Overall, I'm going to try to adapt the OpenCore configuration to my device. But with my limited experience, I don't know what to do if I can't even start and tell if anything works for me :(

But ACPI modifications looks like magic for me  :(


Thank you in advance for any help.

Regards, Marcin




Link to comment
Share on other sites

  • Moderators

try setting your BIOS to load default. Save, reboot. and then go back to set BIOS to 

  • UEFI Enabled
  • AHCI enabled
  • Secure boot disabled
  • Legacy Option ROMS disabled

if still not boot, try disabling your internal drive. Some NVMe drives are not supported. If it boots up with drive disabled, then means you'll need to replace it with a supported drive.

Link to comment
Share on other sites



I've tried clearing the BIOS and resetting it as recommended. No success :(


I've tried to disable drives. Still no success. But as I wrote in the first post: my Toshiba is not NVMe - it is SATA M.2.


So finally I found some time to read carefully Dortania's OpenCore Install Guide and make my own EFI folder. It is not tested yet, but when creating I found:


Configuration Notes


In some cases where you cannot set the DVMT-prealloc of these cards to 64MB or higher in your UEFI Setup, you may get a kernel panic. Usually they're configured for 32MB of DVMT-prealloc, in that case add these values to the iGPU properties:


Key                         Type    Value
framebuffer-patch-enable    Data    01000000
framebuffer-stolenmem       Data    00003001
framebuffer-fbmem           Data    00009000




So in short, DVMT is important and there are two possibilities:

  • change DVMT value, which you can read about in many guides, e.g. here:
  • or change the OC configuration as described in Dortania's Guide.


This change is not only required to have 4K output on HDMI. It is required also for install/run macOS system.


Quickly I corrected config.plist files in the EFI folders, both from @Akerbeltz14 and from @takobaba, and the installation program started. Now I hope  it will go further without additional problems ;)



Link to comment
Share on other sites

  • Create New...