Jump to content

Gratitude D620


iVysaur
 Share

Recommended Posts

All right, chaps?

This week, i decided to give it a whirl with my good old reliable D620 and OS X v10.6.3.

 

The specs of my machine are as follows:

Primary Hard Drive   = 1000 GB HDD
Modular Bay Device = DVD+/-RW

Video Controller       = Intel 945GM Graphics
Video BIOS Version  = 1264
Video Memory          = 8 MB
Panel Type               = 14" Wide XGA
Native Resolution     = 1280 by 800

Audio Controller       = Sigmatel 9200
Modem Controller    = Conexant HDA D110 MDC
Wi-Fi Device            = Broadcom Wireless
Cellular Device        = {none}
Bluetooth Device     = {none}

AC Adapter Type     = 65 W

 

Keen as mustard, my first step was to create a USB installation pen with myHack (like this brilliant guide indicates) and then, almost instantly after i was done, plugged it to my Dell, but because i had forgotten to install the bootpack extra folder for my model on the pen drive, after the gray splash screen everything went black. I realised this when i went back to the guide and after a quick period i was ready to try again.

 

Before i proceed, let me tell you that nowhere did i find any clue about what happens when you install OS X in a HDD that has not been wiped in advance... Pants! I proceeded anyway because i had already replaced my old stock 100 GB hard drive and if anything went wack i could just clone it again.

 

So Disk Utility showed me three NTFS partitions: one was the clone of the Windows XP that came with the laptop, the second one was a fresh install of Windows 8, and the last one was an extra NTFS partition that i made specifically for OS X to find and overwrite. Both Windows 8 and the empty partition were made with GParted from the resulting unallocated space left by the cloning process, for which Clonezilla and Ubuntu Live CD were used.

 

I installed it in the empty NTFS partition after transforming it to the appropriate file format with Disk Utility and off we go! Like i mentioned it before, i heard some odd noices during the first half of the installation, but like Hervé said, it was probably the DVD drive. When this was done, i restarted and was greeted with the OSXLatitude themed Chameleon (lovely jubbly!); up to this point, i had four choices: My Hack USB Installer, Dell Utilities, NTFS1, NTFS2 and OS X, picked the last one and, after watching the SL intro, did what i was prompted to, then bam! In the desktop i was.

 

Here's where i, unable to cope with my own excitement, began losing it out of my head. I installed the EDP and then looked out for the personal configuration for my machine, but for some reason it "beachballed" me in the end. I was expecting a notification window indicating that the process was finished but all i had was this too little to be noticed "done" word inside a white command window. I forced-quit the EDP and restarted, but then i noticed i hadn't installed the 10.6.8 combo, i blindly did it and then, for some reason beyond myself, i re-installed the EDP. Kernel Panic ensued.

 

I repeated the whole process (not really all of it, just the OS X part) a couple of times. I had to install the extras from the bootpack with My Hack again on the pen drive before i could successfully start where i left (actually, before i made bollocks of it, which is right before the combo). I guess it's worth mentioning that during the install i got some Kext-related prompts which i honestly readed carefully this time before any action (choosing yes three times gave me a sluggish cursor): I got rid of the ECC memory kext, kept the not recommended for NVIDIA kext, and... I can't remember about the other one, sorry.

 

Now i have a fresh 10.6.3 running again without EDP and updates, because i wanted to ask here first how shall i execute the update procedure. I can guarantee you that Windows 8 bootes normally with Chameleon, but at first Windows XP didn't want to boot from it, i had to boot into Dell Utilities first and then restart before i could boot XP again. However, after the reboot, Chameleon was gone and Windows 8 boot screen was back, but i'm still able to boot into OS X with the USB drive.

 

I want to thank you all for these tools and documentation, there're lots of places out there devoted to this kind of things, but almost none of them has been as devoted making the process so smooth and painless for beginners, i may even be inspired to try with a HP G60-235DX, but first i'd like to see how it goes with my Dell.

 

Cheers!

 

Link to comment
Share on other sites

  • Administrators

From 10.6.3, you ought to:

1) download and install Combo update 10.6.8

2) when prompted to reboot, don't!

3) download and install EDP. Launch EDP and do a system build for your particular D620 GMA950 LoRes model. You'll need to add the brightness fix too.

 

That's it, you should then be able to reboot in a fresh SL 10.6.8 installation.

Link to comment
Share on other sites

Hello, Hervé, thanks for replying!

 

I ran into the following problem:

PHP 5.4.13 Development Server started at Wed May 15 18:53:21 2013
Listening on http://127.0.0.1:11250
Document root is /Extra/bin/html
Press Ctrl-C to quit.

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000]: General error: 26 file is encrypted or is not a database' in /Extra/bin/config.inc.php:88
Stack trace:
#0 /Extra/bin/config.inc.php(88): PDO->query('SELECT * FROM c...')
#1 /Extra/bin/config.inc.php(12): getConfig('edpversion')
#2 /Extra/bin/launch.php(10): include_once('/Extra/bin/conf...')
#3 {main}
  thrown in /Extra/bin/config.inc.php on line 88
logout

[Process completed]

I still have the restart combo window open.

 

What can i do?

 

Edit: Tried reinstalling and updating EDP to no avail. I'll try again in the morning.

 

Cheers

Link to comment
Share on other sites

Hi, Leon, thanks for replying!

 

I followed your instructions and also this one, which this morning gave me the same message (and then Safari crashed, the edptool.command didn't show anything in the console, except for an empty white window). However, i just did it again right now and it worked (instaling and successfully running EDP, that is, haven't ran the config yet).

 

I just did a fresh reinstall of OS X, though, because i couldn't just live the machine running all night with the 10.6.8 combo prompt to reboot, will run the combo again and try... I must admit, though, that the intro video never gets old! I wonder if there's a boot command to make it run every time i log into OS X.

 

Mega cheers!

 

Update:

I got the following message afte completing EDP config:

 

System extension cannot be used

The system, extension "/System/Library/Extensions/myHack.kext/Contents/Plugins/Ispcidrv.kext" was installed improperly and cannot be used. Please try reinstalling it or contact the product's vendor for an update.

 

Clicked OK and then:

 

System extension cannot be used

The system, extension "/System/Library/Extensions/myHack.kext/Contents/Plugins/NullCPUPowerManagement.kext" was installed improperly and cannot be used. Please try reinstalling it or contact the product's vendor for an update.

 

 

Clicked OK again, crossed my fingers and rebooted, then this:

panic(cpu 0 caller 0x1b66b0fa): "No HPETs available...CPU(s) configured incorrectly\n"@/SourceCache/AppleIntelCPUPowerManagement/AppleIntelCPUPowerManagement-142.6/pmThread.c:157
Debugger called: <panic>
Backtrace (CPU 0), Frame : Return Adress (4 potential args on stack)
0x1b593f08 : 0x21b837 (0x5dd7fc 0x1b593f3c 0x223cel 0x0)
0x1b593f58 : 0x1b660fa (0x1b67d3a4 0x2 0xf61f9879 0x3)
0x1b593fc8 : 0x2a179c (0x0 0x0 0x0 0x0)
	Kernel Extensions in backtrace with (dependencies):
	   com.apple.driver.AppleintelCPUPowerManagement (142.6.0)@0x1b665000->0x1b688fff

BSD process name corresponding to current thread: kernel_task

Mac OS version:
10K549

Kernel version:
Darwin Kernel Version 10.8.0: Tue J	You need to restart your computer (...)
System model name: MacBook2,1		button until it turns off, then press (...)

System uptime in nanoseconds: 170824	Redémarrez l'ordinateur. Enfoncez (...)

Any advice would be greatly appreciated.

 

Second update:

I got around the "panic" by booting into the pen drive and then running My Hack, reinstalled the Extras and then restarted.

Now i'm in the desktop again.

 

Cheers

Link to comment
Share on other sites

  • Administrators

Reboot with flags: -f -v. You should be able to get to your desktop.

 

The 2 error messages you got ("System extension cannot be used...") is the sort of things you get after you've installed a kext but have not (yet) repaired its permissions and rebuilt the cache. However, EDP does that automatically after a system build, so I wouldn't have expected those error messages to pop up.

 

If when you get this sort of things after modifying kexts (add/delete/move kexts), go to Applications, run myHack and select myFix. Apply it to your HDD ("/") and do a full repair (not a quick one).

 

Coming back to your KP, could you:

  • have a look in folder /Extra/Extensions and check for presence of a kext called "NullCPUPowerManagement". I expect that kext to be absent.
  • if it's not already on your system, download and copy a tool called Chameleon Wizard to your Applications folder, then double click on a file called "org.chameleon.Boot.plist" found in /Extra. Do a screendump (move pointer to target window, then press ALT-Left Shit-4 simultaneously, then press Space, then do a left click) of the boot plist tab and publish it here.
Link to comment
Share on other sites

Thank you, Hervé, for your reply (and excuse me for my late one)!

 

This fixed my problem:

 

34ra80n.jpg

 

Everything works so far, more's the pity considering i'm about to do a fresh reinstall once again to get everything working on the first run.

You, chaps, are brilliant.

Thank you for your support.

 

PS: Is there a command to have the SL video intro everytime you boot into OS X? I'd love to know. Oh, and what is the infamous AppleIntelCPUPowerManagement.kext for, what good does it do to the world?

 

Best Regards!

Link to comment
Share on other sites

  • Administrators

The D620 GMA950 does not need the NullCPUPowerManagement kext to run. But it means your boot plist has to bet set for P and C states. There's nothing infamous about the AppleIntelCPUPowerManagement, it's just the standard vanilla kext than handles CPU power and there's no problem with it on your model.

Link to comment
Share on other sites

Hi, Hervé!

 

If my machine does not need the NullCPU(...).kext to run then why is it giving me the bloody panics?

And if i download Chameleon Wizard, will i be able to enable C & P States? If so, how exactly?

 

I'm back to the point when i'm about to install EDP and run its config, right after the combo.

"Emulated speedstep" and "Install VodooTSCync" are on by default under the tab "CPU & Power", does it influence my problem in any way?

 

For the time being, i'm going for "Install NullCPUPowerManagement", because that gets rid of the panic, patching is useless as well.

 

Cheers!

Link to comment
Share on other sites

  • Administrators

You'd be right there: you probably need NullCPU if you use SleepEnabler at the same time. But, whilst the D620 GMA will run fine without both, it may not sleep/wake properly without SleepEnabler. Anyway, if the default settings were to install NullCPU + SleepEnabler, then go with that and ignore my crap. My apologies for getting you confused (too many models and the old fart that I am is getting lost! "Fromage frais!" DelBoy might say...).

 

Re: Chameleon Wizard, once you've downloaded it, just double click on your boot plist in /Extra and you'll understand...

Link to comment
Share on other sites

 Share

×
×
  • Create New...