Jump to content

optiplex 745


Recommended Posts

So made a new MyHack stick today and tried again, same result. With the ATI installed it freezes not even 10 lines into the boot, it basically says:

"Non-POSTed ATI card installed, reading from ROM on card"


And it hangs on:

"Nr of ports set to framebuffer's default: 0"


So the install isn't getting past the video card, that is problem #1.


Problem #2 is that even if I take the video card out and use onboard video (which, will NOT be good if I can't get the ATI to work, I NEED QE/CI), once the installer loads, and I go to select an install location, there's no partitions showing, at all. Launch Disk Utility there's not even a SATA bus visible and thus no drives.


So obviously the first thing I have to do is to get the drives visible to install onto before I worry about the card, but the card will eventually matter too.


I need the help of one or more of the group of 7X5 users who've suceeded in this to get me really started, my Latitudes installed almost flawlessly, but now I need some community support :P

Link to comment
Share on other sites

  • Replies 33
  • Created
  • Last Reply

Top Posters In This Topic

So, I got to where I can see the drives by setting the SATA behavior in the BIOS to "Legacy" - which is a huge pain the a** because every time I restart the 745 it comes up with the "Performing automatic IDE configuration" message and resets the SATA mode back to "Native", and thus can't see the drives again (Any way to make this setting actually STICK so I don't have to go into bios setup with every.single.restart?) What's more, even after installing EDP, MacOS refuses to see a PCI bus on the system (!) Thus, it does not see the PCI Wifi card, which is a MacOS supported card. According to system profiler, the PCI bus basically doesn't exist.


I gathered this was a relatively pain-free machine to hack based on the forum and the fact it's an auto-config on EDP, and actually purchased a barebones 745 based on that impression. Starting to really hit my head on a wall here.

Link to comment
Share on other sites

  • Administrators

Dear Tod,


Your ATI X1300 will work. You need to boot with GraphicsEnabler=No. Chameleon does not inject it properly and hence the error message. I had similar messages without that. You also need to install natit.kext to get your card working. Try the attachment below.




Pertaining to your sata issues, try the attachment below. I used it for lion but not sure if it works in SL.





Link to comment
Share on other sites

Using GraphicsEnabler=no allowed me to startup completely, but installing Natit.kext did nothing for my card. I still have to boot GraphicsEnabler=no, and even though I see natit.kext trying to load stuff in the verbose boot (it scrolls too fast for me to actually read), when I get to the desktop, System Profiler still reports a generic GPU, with 3mb of VRAM, and no QE/CI, and no switchable resolution.


Further, the IOATA kext does not remove the need to boot in legacy mode, and I still have to deal with the BIOS doing a "Auto IDE configuration" every time I reboot the system and switching the IDE mode from Legacy back to Native, thus, every time I want to boot into Mac OS I have to go into BIOS and switch the ATA mode.


Also, neither of these kexts address the lack of a PCI bus being detected in the computer. Is it because the PCI bus aside from the video is a legacy PCI bus, and Mac OS just no longer has drivers in Snow Leopard for an old PCI slot? Is there another kext I need and am missing?

Link to comment
Share on other sites

So, I finally resolved the video by ditching the factory optional ATI X1300 entirely. Fifteen dollars later I installed an ASUS NVidia 7300GT, put 64-bit versions of NVEnabler.kext and NVInject.kext into /Extra/Extensions and ran MyFix and rebooted. Instantly I have resolution switching, and QE/CI, and the acceleration seems to work perfectly.


The issue of having the BIOS reset the SATA mode every time it rebooted out of MacOS was fixed by (1) updating the BIOS to 2.6.4+, then (2) installing ElliotForceLegacyRTC.kext into /Extra/Extensions, again running MyFix and rebooting. Don't know if this is still a problem in 10.7, but might want to update the boot pack and EDP for the 745 with this kext in the 10.6 build. I absolutely could not get the BIOS to stop resetting without it.


Also, I'm pretty sure the installer bootpack and EDP build for the 745 should have IOATAFamily.kext in it, since it was necessary for both Synogar and myself to even be able to see the SATA drive with the USB pen or to get past DSMOS on the installed OS, I'm presuming it's a necessary component, and it's missing from both packages.


The only thing missing now on my Opti745 Hack Pro is WiFi - and I'm pretty sure that's because I was trying to use a standard PCI card and MacOS isn't going to address it. Fortunately I have the 745 tower, which has a single PCIe 1x slot, so I'm going to try using a genuine Macbook Pro Airport card with a mini PCIe to PCIe adapter. Both can be acquired on eBay for less than $20 total.

Link to comment
Share on other sites

  • Create New...