Jump to content

[Solved] D430 and Lion - why can't I install?


ddiego
 Share

Recommended Posts

I'm not ready to give up yet, but getting close!  I made another Lion install USB drive using myHack and the latest compatibility bootpack from OSXLatitude.  I even ran full myfix again just to be sure all files were associated.  However, the system continues to hang where it always has stopped.  I used -f -v -x as well as no boot commands ... same result each time.  Thoughts?  Suggestions?  Should I give up and just buy the real thing??  Help!!!!  Attaching screen shot for your use.

 

FYI - I already have SL installed.  All my components are compatible and the system runs fine under SL.

 

Oh, another FYI.  I own the retail SL disk and purchased both Lion and Mountain Lion from Apple.  So don't bother suggesting I'm using a bad pirated copy...not the case.

post-11927-0-57726600-1373427790_thumb.jpg

post-11927-0-47762400-1373428412_thumb.jpg

Link to comment
Share on other sites

Success at last!   Here's how I did it.

 

1.  Reading on a forum somewhere that repartitioning a USB drive with Disk Utilities may not always remove hidden system files I decided to use Windows to clean my drive completely before partitioning and formatting with Disk Utilities.  I formatted to Fat32, then to NTFS, then back to Fat32 just to be sure.  Overkill?  Probably.  But I wanted to leave no stone unturned.

 

2.  I partitioned and formatted the USB drive in SL to GUID and MAC OS Journaled.

 

3.  I created the USB installer with myHack and the Lion App Installer I downloaded from the Apple App Store.

 

4.  I DID NOT install the bootpack Extras during the USB installer creation.  Instead, I finished the creation, closed myHack, and then renamed the Extra folder on the USB to Extra Backup and copied over the bootpack Extra folder from my downloads folder (having downloaded the latest bootpack from the OSXLatitude compatibility page).  I then ran a FULL myfix on the USB drive with myHack.  One issue here...I could not rename the Extra folder with Snow Leopard but, instead, had to use my D630 Mountain Lion to rename the folder.  I ran into this once before...could someone shed light on why this might have happened?

 

5.  I booted from the Lion boot USB drive and successfully got to the utilities menu.  I erased my perfectly running copy of Snow Leopard and continued with the install.  Quite some time later the install was completed and I got the usual 'installation failure', 'reboot your machine' message (same as with my Snow Leopard install disk).  From past experience I knew I had to boot from the USB the first reboot and install Chameleon Wizard.

 

6.  As soon as my computer booted past the Bios screen I knew I had a problem.  There was something wrong with the Chameloen bootloader on the USB...four lines of code quickly flashed by and then my Windows 7 boot began.  Somewhere in the install process the bootloader on my USB was corrupted.  I checked to see if I could boot from the hard drive but that bootloader wasn't installed and I'd go right into Windows.  Lucky for me I have another Hackintosh.  I simply reinstalled Chameleon on the USB drive and then could use it to boot to my new Lion install.  Well, not right away...

 

6.a... Insert lesson learned here:  It may pay to make a backup Lion installer USB in the event that the install corrupts your USB drive and you DO NOT have access to another Mac or Hackintosh to reinstall Chameleon.

 

7.  I kept getting the usual hang upon reboot (see the picture in my original post).  So I used the flags -f -v -x as well as another that Herve suggested USBBusFix=No.  So the string looked like -f -v -x USBBusFix=No   That worked the trick and accessed the setup screens and eventually got to the main Lion window.  I installed Chameleon Wizard and then downloaded EDP and used tools to create a profile for my machine.  The program indicated that it could not fully associate the kext files because I was in safe mode so I rebooted from the hard drive and hoped for the best.  Lucky for me I booted back to Lion (alternatively I could have booted from my Lion install drive and run a full myHack myfix on the drive). 

 

My cold boot time for Lion is 37 seconds using my mSata drive/adapter setup.  My Snow Leopard cold booted in 32 seconds.  Five seconds is a fine tradeoff in my estimation to get access to the additional features of Lion.

 

I hope this guide helps.  There may be other ways to complete the install using the myHack process, but unless people post their success stories we'll never know...

  • Like 1
Link to comment
Share on other sites

  • Administrators

the pictures above is a chameleon issue. my hack chameleon needs updating. it affects 32 bit arch booting. it would boot with arch=x86_64. which should be ok if you where just trying to install. the issue was corrected in chameleon 2248.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...