Jump to content

D430 Kernel Panic because kexts fail to load


Antithesis
 Share

Recommended Posts

Hello, I have tried installing OS X Lion (10.7) on my Latitude D430 following the regular instructions provided here. The file I used to prepare the USB stick with MyHack was "Mac OS X Install ESD.dmg". Additionally, I configured my BIOS according to these instructions. After installing the correct bootpack, I booted from the USB stick and I got the following errors:

 

FjsS8ca.jpg

 

sfyHpeQ.jpg

 

Anyone got an idea?

Link to comment
Share on other sites

  • Replies 32
  • Created
  • Last Reply

Top Posters In This Topic

Replacing the boot file is the same as updating chameleon? Because I have done that, and now it gets stuck at a gray window with a red-blue-green spinning disk at the top left corner of the screen. It takes about a minute to get there.

 

EDIT: what I've tried next is creating the installer using myHack, then replacing the boot file with the one you've provided, then installing the extras. This resulted in the following error immediately when booting from the USB stick:

 

boot0:GPT

boot0:done

boot1: error

Edited by Antithesis
Link to comment
Share on other sites

Download latest Chameleon from here: http://www.osx86.net/view/3856-chameleon-2.2svn-r2254.html and re-install on your HDD partition.

 

I reformatted the stick, then used myHack to make it a 10.7 installation device, then installed the bootloader using "Chameleon-2.2svn-r2254.pkg.zip" from the link you've provided, then I installed the extras using myHack again, and I booted from that. It resulted in the following screen:

 

g6OM5M7.jpg

 

LmtFZH3.jpg

 

After that, I've tried replacing the boot file with the one Leon provided on the same stick (without redoing any other steps), but it gave the same results.

 

Link to comment
Share on other sites

  • Administrators

I will try out a fresh Lion installation on my D430 later on and will let you know. Meantime, can you tell me which version of myHack you're using to create your USB installer and which version of Lion you're using for your installation (10.7.2, 10.7.4, 10.7.5?).

Link to comment
Share on other sites

Ok, the current bootpack has an issue (a major kext is missing).

 

Try this one, I've just tested it successfully with a default myHack 3.1.2 USB installer (i.e. default Cham boot loader).

attachicon.gifBootpack_D430.zip

It still isn't working for me. After the installer asks me if I want to remove certain modules that result in kernel panics, it continues for a few more minutes, then it says that the installer could not finish. I've tried it twice, and this is what happened both times. The first time, I installed the new bootpack you provided directly after doing what I said I did in the previous post, without formatting first. The second time, I started formatted the stick, created the USB installation disk, installed the extras from the new bootpack in your attachment, and booted from that directly without replacing Chameleon.

 

Here's the error log for the second try.

 

The log of the first try was corrupted and could not be recovered. Hopefully, this is enough. I'm going to retry tomorrow. Was I supposed to install the new version of Chameleon as well? And replace the boot file? In what order should I do things?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...