Jump to content

Dell D630 Shutdown/Restart Issue


pankhil
 Share

Recommended Posts

I have

 

Dell D630 - A15 - Nvidia Laptop

 

Installed OSX 10.6.3 using Leppy Method

Installed EDP 1.8

Updated Extra Folder with Extra folder from this site.

 

I have working

 

Both Cores

Wifi - Replaced with Dell 1395 Broadcom

Ethernet

Trackpad

 

Everything works except the shutdown/restart part

 

I have tried to rebuild the extra folder, replaced the openhaltrestart.kext repaired permissions.

 

Everything that is possible i have done. I have also installed poweroff_bug_fix.pkg

 

my yahoo -- edited by mod: please dont post your mail public ;) --

 

Please assist.

 

Thanks

Link to comment
Share on other sites

Strange.. it works on my D630-nvidia (one that i'm testing on these days)

 

You are running 10.6.7 now.. right ?

 

Yes i have updated, just found a dsdt.aml from insanelymac that fixed it.

 

I have attached the file here, i rebuilded the kext and woohoo i am in business.

 

thank you for all the support

DSDT.aml.txt

Link to comment
Share on other sites

disable usb wake

Haha! I had that problem on my D520 with Leopard. When "Wake from USB" was enabled in BIOS, Shutdown/Restart would not work in OS X. I think "TheGreatDeceiver" over at Insanelymac helped me figure that one out.

Link to comment
Share on other sites

I must say that custom DSDT file fixed my D630 shutdown issues w/A17 BIOS!!. Now everything seems to be working just fine here. I also installed EDP package and that too worked out great. Thanks a lot. This forum is a great resource for users with Dell latitudes.

Link to comment
Share on other sites

 Share

×
×
  • Create New...