Jump to content

D830 Intel Fully working on Lion


Recommended Posts


I got a working USB with myhack and was able to install Lion on a partitioned drive with GUID tabel. I have over 5 partition of my 500gb hard drive, I honestly can not install only lion on my drive, reason being I got SL a back up copy of SL, Win7, Lion and a Gateway drive.

Using EDP 1.9 I was able to get trackpad, keyboard, sound and ethernet working but no WiFi, any suggestions. By the way I found a bit of lagging with the graphics.

Link to comment
Share on other sites

Hi chris88962

can you post the steps...???

I dont know where did i miss, but I am not getting my D830/nvidia running. in fact when I do the update of 10.6.8 (backing up the required kexts) I cannot pass through no errors but the system hangs.

so request you to post the steps exactly that worked for you.

thanks in adv.


Link to comment
Share on other sites


I posted in another thread that I have just ordered a few D830s off-lease, refurbished. Would love to get OS X 10.6.8 (Snow Leopard) on them, and would be willing to wait for 10.7 (Lion), as it is new, and am willing to wait for Apple to get it right for their hardware before OSX86 community works out the bugs.

Did you ever hear back form chris88962 and find out the steps (s)he followed and had achieved a successful install?

The D830s I have ordered have 2.2 Ghz CPU, nVidia GPU, and WUXGA (1920x1080) displays. Wonder if the dsdt.aml used by chris88962, by you, macluscious, simeonoff, LatinMcG, Zeppo or others will impact the ability of these computers to achieve that high a resolution. Thoughts?

nesnfsn in Sunny South Florida

Link to comment
Share on other sites

Finally I got 10.6.8 working on my D830 T7500 @ 2.2Ghz Nvidia NVS140 with 3GB RAM.


Restart / Shutdown works...didn't check sleep.


installed 10.6.0 (10A432), EDP 1.9, Chemaleon from EDP, 10.6.8 combo update and reboot with -f option (was getting KP with voodoHDA).


I didn't install sleep enabler from edp as it was giving me KP and everytime had to boot with pmVersion=0. (thats why I said sleep is not tested)


My system shows macbook3,1 I am trying to install Lion I get an alert "mac osx 10.7 lion cannot be installed on this computer"


please guide me I also tried changing the system definition to macpro3,1 no result.


also found the system fast at times but then it slows down a bit. (will observe)


thanks to all the guys here who have directly / indirectly helped me and many like me.




Link to comment
Share on other sites

Back to 10.6.7 :(


reasons: firstly sleep enabler was not working in EDP. Had to install legecy kernel and sleep enabler from nawcom. But after 2 / 3 boots my system got so slow, a snail cud win the race !!!


tried re-installing several times and trying different setups. Voodoo KPs, Sleep KPs and finally decided to keep 10.6.7 with EDP 1.9 and sleep enabler for 10.6.7 from nawcom.


my system is 100% Mac Snow Leopard 10.6.7 with shutdown/restart and sleep :D


thanks to all the guys out there...


but would love to see Lion on my screen. the only reason I was going ahead with 10.6.8 was to update to lion but always got "Mac OSX Lion 10.7 cannot be installed in this computer" I also changed the system definition as well as in some posts it was mentioned to use chameleon RC5 v1200 or chimera (chameleon, stolen and rebranded) from multifail. none worked. In fact, EDP 1.9 has latest version of chameleon.



do let me know if I can upgrade from 10.6.7 to lion (the copy of lion is not from Apple Store :( )


please let me know how can I go about it.




Link to comment
Share on other sites

I have my system D830 Nvidia running 10.6.8 and wanted to try to setup a cloned drive to Lion. I am trying the install and I am getting


"Mac OS X 10.7 Lion requires a Core 2 Duo, Core i3, Core i5, Core i7, or Xeion processor."


What would be the easiest way to fix this?


What is wierd though is when I go into system info it shows



Core 2 Duo

2.01 Ghz




Thanks anyone



Link to comment
Share on other sites

  • Create New...