Jump to content

Installing 10.9 to D830 - Still Waiting For Root Device


Recommended Posts



I had a working Mountain Lion running in my D830...Today I tried install a fresh copy of 10.9 to the machine, no bios changes were made, i.e. SATA mode was set AHCI.


Using myHack 3.3 to create the USB installer, wiped out the HDD and installed the 10.9 to the same HDD with no issue.  However, after the installation, I am unable to boot from the HDD, stuck in 'Still Waiting For Root Device'.


I tried booting from a USB (with the 10.8.4) and run myhack to install the EXTRA (for 10.9) and run myfix to the HDD, still the same...


Any idea?



Link to comment
Share on other sites

  • Administrators

If you still have the ML installation, do try and compare the contents of your /Extra/Extensions to see if there are any differences. Also check that you have DSDT + Chameleon boot plist + SMBIOS plist in /Extra with identical settings as you had in ML.

Link to comment
Share on other sites

Thanks Herve and Bronxteck...


I compared the files with my ML installation and everything seems to be fine - nothing seems to be missing...


I was finally able to get everything working by doing the following:


1. Re-formatthe HD

2. Install the Chameleon to the HD 

3. Install the 10.9 to HD from the USB installer

4. Install the Chameleon again (strange)

5. Install the 10.9 Extra

6. Run myfix

7. Able  to boot to Mav successfully without entering any flag!

8. Run the EDP to fix the sound


That is all - everything works nicely...



Link to comment
Share on other sites

  • Create New...