Jump to content

WiFi works. Can't see or join networks. 1390 ML D830 Nvidia


Recommended Posts


I have ML on my D830 Nvidia and it works pretty well. The thing is, My wireless icon is always blank, but it will connect to my wireless network, and it lists my wifi adapter as off. It'll search for networks but never find any and trying to turn the adapter on does nothing. It's a Dell 1390. Good thing I live in the sticks and don't need security on my router. *For some reason I thought it used to work and I did find my old network listed, I haven't used OSX in awhile*


I've searched around but I haven't found a solution yet. My BIOS is set up like all of the guides say. Catcher is off, switch is off etc. I've tried looking for a new kext but I haven't found any of those either (I guess since it's supposed to have native support). I've tried a few things in EDP but all I've managed to do was somehow break the AppleACPI.


I'm not exactly a noob, but I'm also not very familiar with Hackintosh. I'm really afraid that if I keep messing around  it's just going to stop booting. I tried an install of Mav thinking that might fix it but that was a disaster and never even installed.


Any thoughts, anyone?


Thanks ahead of time.

Link to comment
Share on other sites

Thanks for the reply.


I didn't find any fixes in the link that you provided.


I messed around with EDP some more and set up a second router to test with and I can now join other networks but the wifi status icon still doesn't work and only gives my the option to turn on the wireless. So that's still broken.


It's not a big deal I guess but it would be nice if that worked.

Link to comment
Share on other sites

  • Create New...