Jump to content

D820 nVidia - "Panic" error upon reboot


Recommended Posts

Troublehooted a bit using the - x - v.   The cause is this kext  apple.driver.apple.driver.AppleACPIPPlatform



I have rebuilt machine 3x with same issue.  When rebooting after install, edp fixes, software updates etc machine will not boot. 

I get an error that the boot o not loaded (something like that) Another text screen appears saying to shut down a restart.  


In order to recover I had to do the build from scratch.  Erased drive, Installed My hack items, installed Snow Leopard, Then loaded EDP.  Loaded custom scripts and tools which fixed the sound.  


In other threads it says if you have an issue with rebooting to use Chameleon Wizard?  How / where do you get to that?  I have not been able to figure that out.   There is a Chameleon module in EDP but not sure what to do.  


Baby steps please,  What should I do next?   Thank you for your help.    


I did use the -x - v  to troubleshoot


Here is the message that appears when you boot:  (I manually typed this so there might be some small types)


npvhash - 4095

PAE Enabled 

64 bit mode enabled

Darwin Kernel version 10.3.0 : Fri feb 26  11:58:09 PST 2010;  root xnu 1504.3.12-1/Release I386

vm_page_bootstrap: 507833 free pages and 16455 wired pages

standard time slicing quantum is 10000 us

mig_table_max_dispt = 73 

SAFE BOOT DETECTED - only valid OSBundleRequired kexts will be loaded

kext_kernal is not loadable during safe boot: omitting is personalities. 


kxldfcom.apple.apple.driver.apple.driver.AppleACPIPPlatform  the super class votable .... blah blah blah   is out of date make sure your kext has been built against he correct headers.   

Can't load kext com.apple.driver.apple.driver.AppleACPIPPlatform

failed to load executable for kext apple.driver.apple.driver.AppleACPIPPlaform

Kext.com.apple.driver.apple.driver.AppleACPIPPlatform  failed to loan ( with a hex a decimal)  

failed to load kext com.apple.driver.AppleACPIPPlatform (error 0xdc008016).

Couldm't alloc class "AppleACPIPlatformExpert" 




Panic (spu 0 caller ox558271):  Unable to find driver for this platform: \ "ACPI\".\n"@SourceCache/xnu/xnu-1504.3.12/iokit/kernal/IOplatformExpert.cpp:1389

Debugger called: <panic> 

Backtrace (CPU 0 ), Frame : Return Address (4 potential args on stack) 

(There are a lot of hexadecimals)  

BSD Process name corresponding to current thread:  Unknown


Mac os version:  

Not yet set 


Darwin Kernal version 10.3.0 Fri...... (can't see) 

System update in nanoseconds .....  


You need to restart your computer.  Hold down the power button until ti turns off then press the power button again.  (Says it again in several languages)  



Link to comment
Share on other sites

Silly question in between -  When I have been doing this I can't get it to boot up to the MAC to run EDP.  So the only solution that I have seen is to wipe the drive, Instally my hack (all the parts), Install Snow Leopard, then install EDP  .... then do the custom option .... 


Is this correct?  Or is there a short cut?  


Thank you 

Link to comment
Share on other sites

Tried removing the file and all it did was hang at a blue screen when it rebooted. 

I am going start the whole process over from scratch to see if I can find out what I did wrong here.  


Dumb Question -  When you load the OSX from the USB (with the my hack stuff too)   why do you have to run EDP again once it is installed to make stuff work?  


When you create the Install USB shouldn't that pick up the right kexts to begin with?    The only reason I ran EDP again was to address two issues 


1. No voice / sound 

2. Hibernation...soon as that happens I get an unrecoverable black screen.  


Is there another way to address this issue than running EDP again post install?  


So again this is what I did 


1. Ran install USB... used utilities to wipe drive... installed my hack... and Chameleon, Extras and all the right stuff.  

2.  From the USB loaded OSX.    It loads... stops at a certain point and the screen goes black... I am assuming that it stopped... (if it is hibernating then I have no idea how to stop it from hibernating during the OSX install.)  

3.  Reboot OSX loads...get welcome screen and all that jazz. I get wireless connections... but no sound... no hibernation control.  

(I can reboot in this state with no issues) 

4. Go to the OSX Site... load the EDP.  Run the build .... get a kext (one above) was not or had problem installing ... reboot... will not reboot.  

5.  Got access to the drive via the USB..tried renaming the kext... get a blue screen and no further.  

6. Tried to go back and rename the kext back to what it was and then the same issue above happens again..  


Any ideas?  


Thank you 

Link to comment
Share on other sites

  • Administrators

Which D830 model is this, Intel X3100 or nVidia? It seems EDP is totally screwed these days, so it's probably best to avoid it for the time being.


If all that is giving you trouble are audio + KP on wake, simply use VoodooHDA (or patched STAC9205) kextpack and change sleep mode to RAM only through Terminal command sudo pmset hibernatemode 0.

Link to comment
Share on other sites

It is a D820  Nvidia I believe is the type 


Thank you for that.  


Where do I find this -  VoodooHDA (or patched STAC9205) kextpack? 


Do you know of any instructions to manually install them?   


Thank you for the tip on the hibernation.  


Thank you 

Link to comment
Share on other sites

  • Administrators

Thanks for specifying your model, it kinda helps...


These kexts will be available through the EDP system build. If you want to install them manually, simply copy them to /E/E and run myFix (quick). If you machine is dead upon EDP build, make sure to copy the ACPI kext from the downloaded boot pack; that should give you a working machine again.

Link to comment
Share on other sites

Thank you very much.    I am  in the process of rebuilding the bootable USB to start over to see if I can do this smarter next time.  


When you said  "These kexts will be available through the EDP system build. If you want to install them manually, simply copy them to /E/E and run myFix (quick)."  Where I am copying them from?   I realize that may sound stupid, but I haven't figured that out.   Sorry if this is a dumb question.   On my host mac I am trying to see if I can make it part of the USB, I downloaded the EDP and saw if I could extract or see the files... no dice... it seems to be inside the app.   Is there a way to pull out the kexts from the EDP, or perhaps they are called something else?  


The problems I am trying to resolve are 


1. Sound -- VoodooHDA (or patched STAC9205) kextpack?

2. Hibernation (you gave me the fix to use) 

3. LAN port (which I did not mention before. I have wireless working, (well before I did I bet it will work again when I rebuild)   I get amber lights, not green ones.  

Link to comment
Share on other sites

  • Create New...