Jump to content

Mavericks 10.9.4 M4400/E6400/E6500 Tuning + Improvements


iindigo
 Share

Recommended Posts

The idea behind this thread is to share tweaks and tips for running 10.9+ on M4400s. These findings may also apply to similar models, but the focus is on the M4400.

 

I've been running a setup based on DaFOB's Guide. It runs well, but there's always room for improvement… especially since the guide was really more geared for the E6400/E6500 and some of the supplied kexts aren't necessary for M4400 users. Furthermore, it seems that research on these machines has been at a standstill for a while now, and there are bits that may be able to be improved.

 

Here's my setup:

Precision M4400 - BIOS Rev A29 • T9400 • Quadro FX 770M • OS X 10.9.4 • Chameleon build 2378

 

So far, I've found that the system continues to run properly after removing the following kexts from DaFOB's pack (thanks to wern apfel):

 

               Kext                                    Reason                    

AppleIntelIntegratedFrameBuffer    M4400 does not employ integrated graphics

       DisableTurboBoostBattery    Turboboost is a Core "i" series feature

                     OSXRestart    Restart works fine without it

          Patched_10.7_AppleRTC    CMOS reset is not an issue

                     VoodooSDHC    Known to cause trouble and doesn't work anyway

 

After removing these, my system is still completely stable and functional. In addition to this, AppleSmartBatteryManager (v1.3) can be updated to Rehabman's newer ACPIBatteryManager (v1.5) without issue.

 

—————————————————— 

 

One thing that seems odd/unclear to me is the necessity of AppleACPIPlatform v1.3.5. Some people seem to be able to run with a vanilla version while others cannot boot without v1.3.5 (I cannot boot without it). What is the reasoning behind this?

 

Also, there is a patched AppleHDA that makes for a promising replacement for VoodooHDA. However, I cannot seem to get it working, even though the pinouts and codecs match perfectly. I suspect this is due to the aforementioned use of a patched/rolled back AppleACPIPlatform, as other having similar trouble reports such problems. The kext is attached for anybody interested in trying their luck. Please note that you will have to adjust the HDEF layout ID in your DSDT to 0; the current value of 12 won't work with this kext.

 

One last thing that I noticed is that with the modified FakeSMC supplied in DaFOB's pack is that its smc-compatible key should be set to smc-mcp instead of its current value of smc-napa in order to match up with the SMBIOS model of MacbookPro5,3. That said, I haven't seen much of a change after making this correction myself.

AppleHDA IDT 92HD71B7 (E6400:E6500:M4400).zip

  • Like 1
Link to comment
Share on other sites

  • Administrators

The use of the older AppleAPCIPlatform kext from SL (v1.3.5 from 10.6.7 or v1.3.6 from 10.6.8) is indeed required for Lion and Mountain Lion to avoid KP; it is not usually required for Mavericks as systems normally run perfectly Ok with the vanilla version (v2.0 from memory). I have installed Mavericks on many different Dell systems (D430, D630n, D830n, E6420, E6430, Vostro 200, Precision 670) and never had to revert to the older AppleACPIPlatform kext.

 

Initially (in 2011 - or was it 2012?), this was a fix for CoolBook which stopped working in early versions of Lion unless reverting to what was a the time SL 10.6.7 AppleACPIPlatform kext. If I remember right, Lion 10.7 to 10.7.2 or 10.7.3 could boot with vanilla AppleACPIPlatform kext, but subsequent versions could not. 10.7.4 brought a bit of mayhem when it got out and the older SL AppleACPIPlatform kext fixed the KPs at boot time. I vaguely remember that you could use older Lion versions of that kext but they caused extremely long boots and shutdowns. Maybe things would have worked better if reverting the IOPCIFamily kext too as the two kexts kind of work together.

 

Anyway, that's history now. You'd have to search the forum to get the full story which eludes me a bit 2 to 3 years later...

Link to comment
Share on other sites

Well that's interesting. I'm not sure if my system is panicking or not when attempting to boot with only v2.0; if I boot it that way in verbose mode, the messages simply stop and the system seemingly hangs after mentioning the loading of FakeSMC and ACPIBatteryManager/AppleSmartBatteryManager and a backtrace.

Link to comment
Share on other sites

Beautiful, this fixed the issue entirely! I'm now booting on vanilla AppleACPIPlatform with the latest (custom tuned) FakeSMC-kozlek. As I suspected, the old AppleACPIPlatform was what was interfering with the AppleHDA in the original OP; I now have fully working audio without VoodooHDA!  Note that the AppleHDA must be in /S/L/E/ in place of the vanilla kext.
 
Here's my Extras folder as of now:
M4400.png
 
I also tweaked the DSDT slightly to reflect the proper graphics card.

Link to comment
Share on other sites

Here is a pack of all the changes mentioned in the thread so far. The E6400/E6500 pack will probably work, but it was adjusted based on guesswork as I do not own these machines and cannot test it. I'm interested to hear results with both.

 

Areas which could still be improved:

• GPU temps - If HWMonitor is reporting correctly, the 770M always runs at its max clock speed of 500Mhz, meaning it idles at ~55°-60°C (even with good TIM and a copper shim). This is true with every configuration I've tried thus far.

• Clover - I had a brief trial with this a few days ago, but had trouble finding the correct configuration. It ran acceptably well, but had strange bugs… most notably, audio playback was extremely choppy (voodoohda) and the transparent part of some window shadows would occasionally turn solid black.

• Sleep - This has never worked for me, even with pmset 0. With DaFOB's pack, the machine would restart when told to sleep, and with my current pack it turns off the screen and wifi but never actually sleeps.

• AppleHDA - Auto patching

E6400 E6500.zip

M4400.zip

  • Like 1
Link to comment
Share on other sites

Hi, I have the same issue like you in first post. In Maverick 10.9.5 I use ACPIPlatform 1.3.5 to booting OSX. So If I want to use vanilla original AppleAcpiplatform, must in Bios disable VT, right? And also I use voodoohda, because patched appleHDA doesnt work on my e6500. I tried many version of patched AppleHDA in Maverick and now also in Yosemite, still doesnt work.

Link to comment
Share on other sites

You can have VT-D enabled, but as bronxteck mentioned you need to set the dart=0 flag in Chameleon. For the patched AppleHDA in this thread to work, make sure your audio layout ID is set to 0 in your DSDT and that the AppleHDA is installed properly in /S/L/E/ (Kext Drop does this perfectly for me every time). Obviously any HDA Enabler/Disabler kexts or chameleon flags need to be removed.

 

For the Yosemite version of this kext please see http://www.insanelymac.com/forum/files/file/188-applehda-for-dell-latitude-e6400-idt-92hd71b7/

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...