Jump to content

E6520 working on Yosemite 10.10 - NVS 4200M disabled and HD3000 (Optimus Enabled)


Recommended Posts

Well I got my E6520 working on Yosemite 10.10 after spending some time this evening !! I think pretty much everything is working.


I got it installed in a similar way as I had Maverick installed. I had Maverick (10.9) working on a partition. See my post: Dell E6520 with NVS 4200M on Mavericks . I created a partition (InstallYosemite) and loaded Yosemite using the following command:


sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/InstallYosemite --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction


Then, created /Extra in the InstallYosemite partition. I was able to boot after specifying -x option and installed Yosemite to the new partition. I believe I was using MBeast boot loader which was based on Chameleon v2.2 r2404. After OS was installed, I had problem booting from the partition. Tried MBeast, Clover, myHack, and other version of Chameleon. I ended using the latest Chameleon (Chameleon-2.3svn-r2510) and able to boot and upgrade extensions. You can skip extension upgrade steps and simply use the attached Extra. Don't forget to run KextWizard to update the /Extra and /S/L/E !



- Graphics  (no lagging) - same DSDT

- Sound - same AppleHDA

- Battery - same ACPBatterManager

- Touchpad - same VoodooPS2Controller

- CPU stepping - same SSDT

- Disk - TRIM Patch IOAHCIFamilty.kext 10.10.x

- Network - AppleIntelE1000e v3.1.0

- FakeSMC v6.11.1328

- AppleACPIPlatform v10.9.5


Let's forget to credit where due:

- OSX Crew - Disable NVS4200M and using H3000 (Optimus enabled)
- E6520 on Mountain Lion by lgashu http://forum.osxlati...-mountain-lion/
- collection of 10.9 kext from iFail
- ssdt generation - RevoGirl's blog
- touchpad - RhabmanMerg
- SDHC - heemsker
- others that I missed



Extra-Yosemite-Install                 put this into / of the Yosemite installation partition

Extra-E6520-Yosemite-<date>   put this into / after installing Yosemite; if I update extensions, I will provide updates with a different date



  • Like 2
Link to comment
Share on other sites

Okay, so the DSDT didn't work for my computer. It actually made the screen blank... Does anyone make them for people? Also, I have yet to get sound working and it's possible I'm missing something...




I should mention when installing OSX, vanilla from app store, using unifail. I can boot into a clean system and it full sees the nvs 4200 and uses it. I do have optimus disabled. I don't have uefi enabled. touchpad doesn't work even with voodoops2 drivers installed. I'm on 10.10.2. A19 with an i5-2430m, 8gb, 3tb. sdcard is disabled. express card 3.0 is seen but doesn't see anything plugged in. Tried the computer without that card too.

Link to comment
Share on other sites

Okay, so I managed to get sound working. Windows, Linux and MacOS all say I have Intel HD Audio. IDT driver have never worked in any OS. So I used Chameleon Wizard and set audio to Intel HDA and BOOM! Working audio and HDMI audio. I can't get get a bootloader installed I noticed I don't have an EFI partition when running 'diskutil list' and I am MBR partition layout. I get boot0: error. I've dont EVERYTHING to get it installed but no luck so far. Also, no working sleep yet either. None of the DSDTs linked to have worked for me. Funny enough my NVS4200M works great OTB. Oh, and I have the battery with the X. :(





Got my USB 3.0 Expresscard working. It uses the Fresco Logic chipset, thanks to Rehabman for the drivers.

Link to comment
Share on other sites

  • Create New...