Jump to content

Latitude E5420 Yosemite


Kransbox
 Share

Recommended Posts

You mean E5420?

E5440 has a Haswell CPU with HD 4600

E5420 has a Sandybridge CPU with HD 3000. 

The guide might work but not the kexts and DSDT/SSDT.

See the guide for E6x20 Yosemite. 

 

Merry Christmas!  Thanks for the reply.

 

I'm probably asking to be spoon fed here, but do you have any idea which collection of kexts I should gather, and if there is already a modified DSDT/SSDT for this model (e5420) out for Yosemite?  I looked at the guide in your signature called Yosemite Guide, but I think I'm going to need my hand held a little more.  Would you be willing to take this to PM land, or should I start my own thread?  What is your advice.

 

I'll have to look into how one patches the DSDT/SSDT (and how one obtains it first).

Link to comment
Share on other sites

Follow my Yosemite Guide, use the bootpack from Post #2. I just uploaded a dsdt for E5420

Thanks man.  I tried it once and got a KP.  So I am trying it again.

 

Step 15 doesn't work for me - I get a Write Permissions Error. (-61) on the BaseSystem.dmg when I try to make it visible in order to access the OS X Base System.  Since I couldn't do that I just used the Basesystem.dmg as the source.  I suppose that caused the KP?

 

Edit:  Nevermind got it (the -61) taken care of.  Lets see if I can get this working

 

 

Edit 2:  18. Copy “Packages†from /System/Installation of “OS X Install ESD†to /System/Installation of â€œInstall OS X Yosemiteâ€

 

Is the "packages" that I am to copy the FOLDER called Packages?  That is the only "packages" that I can find in the OS X Install ESD (and it seems to be at the root of the dmg, not in the /System/Installation location) - I can't even find that location on the OS X Install ESD

 

Link to comment
Share on other sites

Tried it again with another USB and KP all the same.  Here are a couple points in your tutorial that I may have did wrong.  Please let me know:

 

1.  See the step "18" comment above for clarification

 

2. I downloaded the file you created especially for me and renamed it to Extra and put it in the root.  It is called Extra.aml   (it is not in a folder or anything like that, just the bare file in the root of the drive)

 

3.  In your post #2 in your tutorial thread you state to rename it to the model number of the laptop.aml but in your original tutorial on step 27 you say to name it Extra and put it in the root.  The post #2 seems to indicate a folder /Extra?  Regardless I am not sure if that would cause a KP

 

 

Thanks for your help thus far.  I appreciate your free help for noobs like me.  I'm not sure how to show you what caused the KP.  I could take a pic with my phone and upload it.

 

 

post-14457-0-80173400-1419559592_thumb.jpeg
 
I'm not sure why the forum rotates the picture?  It is not rotated on my desktop.  Sorry
Link to comment
Share on other sites

  • Moderators

@Kransbox

 

1) you're right, it is on the root, I wonder why no one corrected me before. Guide is now updated.

2) the files I uploaded for E5420 should be rename to DSDT.aml and place in /Extra

3) Download Exx20, it's a folder, name it "Extra". Remove all the *.aml files in it and place the above DSDT.aml here.

Follow the step in post 2, # 3 to generate your own SSDT.aml base on your CPU, and place it in /Extra as well. ssdtPRgen.sh is included in Exx20 folder

 

Do all the steps here and you should not get a KP.

By the way, what's the display resolution of your system? the DSDT I uploaded is for dualLink (resolution higher than 1366x768)

Link to comment
Share on other sites

 

 

 

Thanks Jake.  I do have progress!  I have a black screen now instead of a KP - probably because my native resolution IS 1366x768

 

I assume this can be fixed? 

 

Here is a Non Focused Video (from my phone) of the booting process with flags -v -f  I articulate the last thing that I can see before the text quickly pops up and then the screen is black

 

https://www.facebook.com/video.php?v=10100247844609876&l=8741971387345174901

 

Also, I ordered this from Ebay:  http://www.ebay.com/itm/351249693526?_trksid=p2059210.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

 

Any thing I can load software wise (or edit) so that when this comes in all I'll have to do is physically install it?

Link to comment
Share on other sites

Sorry, I uploaded the file again to post #2. Select the file that saids DSDT.aml in the folder and replace the one in your Installer

See more detail regarding that wireless/bluetooth combo card here.

 

 

Again, progress thanks!

 

THe install process went well.  When the computer rebooted and came back to Chameleon I chose Macintosh SSD  (the logo was a lion with the word RAID built into it).

 

I booted with -v -f

 

it immediately came back and said:    Can't find /System/Library/Kernels/kernel

 

Odd, as I put it in the folder as per step 20 - I just checked the contents of the install usb and the Kernel file (10.6MB) is located where you told us to put it (so I followed the tutorial correctly) -  /Install OS X Yosemite/System/Library/Kernels/kernel

 

 

any thoughts?  Just try again from step 1?  I appreciate your help/patience

Link to comment
Share on other sites

 Share

×
×
  • Create New...