Jump to content

[Solved] Can't boot with patched AppleIntelFramebufferAzul.kext


loibi93
 Share

Recommended Posts

Hello everyone !

Since my old laptop has a cracked screen i can't use it as a normal laptop, but everything else works fine, so i thought i can use it as a desktop machine with attatched monitor.
I have a HD4400 which requires a patched Version of AppleIntelFramebufferAzul.kext for working DisplayPort Output. Also i need a patched kernel for Haswell CPU. 
I created my Boot Drive on my current Laptop with unifail. I put my necesarry kexts in Extra Extensions. DSDT and SSDTs in Extra, and replaced the AppleIntelFramebufferAzul.kext and kernel files with the patched ones. I was able to install with -f -x -v
After that i only had to recopy the kernel file to my hard drive. I plugged in a usb drive with clover configured correctly for this laptop (After this one broke, i bought the exact same one again, so i can use the files from that one). I can boot with only kext-dev-mode=1, but unfortunately i don't have QeCi. So i installed the patched AppleIntelFramebufferAzul.kext with Kext Utility, but when i start, the Laptop restarts after Bluetooth Missing Message. When i boot into installer and rename the .bak to .kext it boots again, but with no QeCi !

Why does it work on my current laptop but not on that one. Before it broke i already had Yosemite installed on it, but i swapped the drives, because the new one only had an sshd and this one an ssd. 

Any Suggestions ?

Link to comment
Share on other sites

They have, but Yosemite was already installed on my wrecked laptop and everything worked fine ! I only have to reinstall because i swapped the drives between the two laptops !

 

Wrecked Laptop: i5-4200U HD4400

New Laptop: i5-4210U HD4400

Link to comment
Share on other sites

I had an ssd in the wrecked laptop. The new laptop shipped with an sshd. I swapped the two drives. I had to reinstall on the new laptop and obviously on the old too since the sshd was empty !

 

Do you mean by generating a new kernel cache that i should give Kext Utility a go ? If yes, i already did !

 

BIOS settings are correct, since Yosemite worked on the wrecked Laptop !

Link to comment
Share on other sites

  • Administrators

how about bios versions? if everything was truly exactly the same swapping drives would not have been an issue at all. the devil is in the details which is a bit lacking. i still don't even know if your using a 7440 laptop or just it's extra folder on another type of system.

Link to comment
Share on other sites

Wrecked Laptop:
Lenovo ThinkPad T440s
i5-4200U @ 1.6GHZ
HD4400
SSHD 500GB
12GB Ram
 
New Laptop:
Lenovo ThinkPad T440s
i5-4210U @ 1.7GHZ
HD4400
SSD 256GB
12GB RAM
 
BIOS are the same Version !
 
I installed Yosemite on the Wrecked Laptop with the help of Dinesh Kumar who is one of the DSDT Patchers here, i think you know him.
Everything worked fine, so i know which kexts i have to use, which Clover Config i need, and also i still have the correct DSDT and SSDTs which he patched for me.
 
Then the Laptop got wrecked, but still worked fine with a monitor attached to it.
 
Then i got the new Laptop which is basically the same. Since i use it the most, i put the SSD from the wrecked Laptop in it. SInce it didn't just boot from the SSD i had to install Yosemite from ground up. I used all the files i already used on the wrecked Laptop. After some tinkering i got it to work.
 
SInce the Display on the wrecked Laptop is unusable i had to configure in the BIOS to output to DisplayPort instead of BuiltIn Display. I managed that by controlling both Laptops simultaniously side by side, so i can see on the new Laptop where i am navigating to.
 
Then I created the unifail Stick, put all my Kexts and ACPI Tables on it. Also i swapped the original Framebuffer Kext with the patched one i also use in the new Laptop. It works fine in the new Laptop, and also worked fine in the old Laptop. Also i patched the Kernel on the installer Stick for Haswell Reboot.
 
After some tinkering i got into the Installer and installed Yosemite. After Reboot i booted into the installer to copy the patched Kernel onto my Hard Drive. I then was able to boot with Clover. I attached my Config.plist so you can have a look. 
 
I can boot without save mode, but i don't have QeCi. DSDT is patched for my HD4400, so it should recognize, but it doesn't. I also tried to inject ig-platform-id with Clover but no success. Then i thought that something went wrong with the Kext during the install, so i reinstalled it with Kext Utility, but after reboot the Laptop restarts when it should show the log in screen. 
 
I hope i didn't forget anything and you can help me now :)

 

http://www.file-upload.net/download-10099432/config.plist.html

Link to comment
Share on other sites

 Share

×
×
  • Create New...